php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17082 php4.2 and apache2.0.35
Submitted: 2002-05-07 16:47 UTC Modified: 2002-05-07 19:31 UTC
From: liorm at fibertel dot com dot ar Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: Linux
Private report: No CVE-ID: None
 [2002-05-07 16:47 UTC] liorm at fibertel dot com dot ar
Hi there

I'm trying to install PHP 4.2.0 with apache 2.0.35 with no luck. When I install it as the INSTALL file says, I create a .php file and my browser tries to download it instead of showing it as a php script. Then when I try to compile it with the LoadModule option in httpd.conf, I run apachectl configtest and this is what it says:
Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: undefined symbol: core_globals_id

Any ideas what could be causing this?.
Thanks
Lior.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-07 16:52 UTC] liorm at fibertel dot com dot ar
Hi there

I'm trying to install PHP 4.2.0 with apache 2.0.35 with no luck. When I
install it as the INSTALL file says, I create a .php file and my browser
tries to download it instead of showing it as a php script. Then when I
try to compile it with the LoadModule option in httpd.conf, I run
apachectl configtest and this is what it says:
Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: undefined
symbol: core_globals_id

Any ideas what could be causing this?.
Thanks
Lior.
 [2002-05-07 19:31 UTC] aaron@php.net
The version of PHP that this bug was reported in is too old. Please
try to reproduce this bug in the latest version of PHP (available
from http://www.php.net/downloads.php

If you are still able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".

Try using Apache 2.0.36 and PHP 4.2.1RC2. Numerous
fixes in both of these may have solved this. If not
feel free to reopen this bug, but be sure to include
both your Apache and PHP configure parameters.
 [2002-07-31 12:23 UTC] metoo at trustlab dot com
hello. I think I've mangede to reproduce the error.(?)
After I installed apache 2.0.39 and php 4.2.2 I managed to get this error:
root@egon:/www/bin# ./apachectl start
Syntax error on line 206 of /www/conf/httpd.conf:
Cannot load /www/modules/libphp4.so into server: /www/modules/libphp4.so: undefined symbol: core_globals_id
root@egon:/www/bin#

The line in httpd.conf is:
LoadModule php4_module        modules/libphp4.so

The machine runs slackware 8.0 with kernel 2.4.5
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 02:05:43 2022 UTC