php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17080 Cyclic Link error
Submitted: 2002-05-07 14:06 UTC Modified: 2002-05-07 14:08 UTC
From: poulman at wirsbo dot com Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.2.0 OS: RedHat Linux 7.2
Private report: No CVE-ID: None
 [2002-05-07 14:06 UTC] poulman at wirsbo dot com
This web site works fine under:
Apache 1.3.22 / PHP 4.0.6
Apache 1.3.24 / PHP 4.1.2

Stopped working with:
Apache 1.3.24 / PHP 4.2.0

Did something change with the way global variables or form 
variables are handled from versions < 4.2 to current?

below is what seems to be one of the offending lines of 
code. Basically, all it is doing is checking for the 
existance of 2 query strings which are passed in and used 
as global variables for several other functions within the 
site.

if ( ! $pm || ! $pc ) {
  header( "Location:     
main.php?pm=1&mm=0&sm=0&pc=homeowner/ho_mm0sm0.php");
    }


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-07 14:08 UTC] rasmus@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
 [2002-05-07 14:27 UTC] poulman at wirsbo dot com
Thank you for your extremely prompt response! The 
'register_globals' setting was indeed the problem. I 
greatly appreciate your assistance.

Pete Oulman
Uponor Housing Solutions Division
North America
www.wirsbo.com
 [2021-04-06 10:40 UTC] git@php.net
Automatic comment on behalf of roojs
Revision: https://github.com/php/pecl-tools-svn/commit/066d7ecee88cfad088184e7afa9dc595201dd570
Log: fix bug #17080 - svn_mkdir requires log message, also added utf8 checks. (Ivan P)
 [2021-04-06 10:40 UTC] git@php.net
-Status: Not a bug +Status: Closed
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 20 18:05:43 2022 UTC