php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17046 I new install 4.1.2 to 4.2.0 not work my php web site now
Submitted: 2002-05-06 12:50 UTC Modified: 2002-06-12 08:10 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: alparslan at karfen dot com Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.2.0 OS: windows 2000 server
Private report: No CVE-ID: None
 [2002-05-06 12:50 UTC] alparslan at karfen dot com
i have this error now my web site.

Warning: Failed opening 'includes/languages/english/' for inclusion (include_path='.;c:\php4\pear') in C:\Inetpub\gayem\admin\includes\application_top.php on line 194

my script search path this -->
Directive	Local Value 		Master Value 
include_path     .;c:\php4\pear	.;c:\php4\pear 


but first php 4.1.2 not search this path ...

thanks

Alparslan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-07 04:59 UTC] alparslan at karfen dot com
Warning: Failed opening 'C:\Inetpub\gayem22\phpinfo.php' for inclusion (include_path='') in Unknown on line 0


this error on version 4.0.6  for phpinfo.php file.
 [2002-05-15 16:53 UTC] mj@php.net
This does not appear like a PEAR specific problem. I guess that you're trying to include a file that does not exist in the specified location.
 [2002-06-11 16:41 UTC] flozada at interalia dot net
I have the same problem since I upgrade to PHP 4.2.1.

PHP Fatal error:  Failed opening required 'PEAR.php' (include_path='.') in c:\php\pear\scripts\pear.in on line 28

If I use the CGI version it crashes generating a GPF, ISAPI DLL send that message to the log.
 [2002-06-12 08:10 UTC] cox@php.net
Some comments for this issues:

1) (alparslan@karfen.com) If the file you are trying to view with your browser hasn't the properly read perms PHP will show up a (I completely agree: nothing clear) message like:

Warning: Failed opening '/home/httpd/html/test.php' for inclusion (include_path='.:/usr/lib/php') in Unknown on line 0

2) (flozada@interalia.net) The PEAR base dir (by default /usr/local/lib) **needs** to be in the include path in your php.ini. Alternatively you can set that path in the code with ini_set('include_path', <dir>);

Tomas V.V.Cox
 [2002-10-19 01:59 UTC] cornel at digitalage dot co dot za
What is wrong with the developers of php this problem keeps making things difficult for windows programmers since i had to move and edit every include file on my site this is seriously annoying that u keep saying it is bogus
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 22 14:01:24 2020 UTC