php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17014 pcntl_wexitstatus does not return exit status
Submitted: 2002-05-05 10:15 UTC Modified: 2002-09-04 03:57 UTC
From: jparneodo at yahoo dot fr Assigned:
Status: Closed Package: *Extensibility Functions
PHP Version: 4.1.2 OS: RedHat7.2 and RedHat7.1
Private report: No CVE-ID: None
 [2002-05-05 10:15 UTC] jparneodo at yahoo dot fr
On Red Hat 7.2 and Red Hat 7.1,
pcntl_wexitstatus does not return exit status,
pcntl_wexitstatus returns 0.
when child process call [exit(1);]
and when father process run:

pcntl_waitpid($pid,$status,WNOHANG);
if(pcntl_wifexited($status)){
	$exitstatus=pcntl_wexitstatus($status);
}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-07 20:59 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-09-04 03:57 UTC] jparneodo at yahoo dot fr
No problem with my new RH 7.3,
so now, cannot reproduce it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 21:01:23 2020 UTC