php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16943 Undefined variable
Submitted: 2002-05-01 08:44 UTC Modified: 2002-05-01 10:39 UTC
From: krizz at krizzbeatz dot de Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 4.2.0 OS: Windows XP
Private report: No CVE-ID: None
 [2002-05-01 08:44 UTC] krizz at krizzbeatz dot de
Hello....

The following programm works, but not on my computer...
the variable "email" always is empty on my system, even if i filled the input box. A friend of mine testet it too, and it works fine on his system.But on my system the Html output appears in the browser. I fill something in the inputform, i press on the "OK" button , but nothing happens... I  use this programm with Apache/1.3.24 (Win32) PHP/4.2.0RC4 running...

can u find a mistake? i cannot... 


<?
  echo "Newsletter";
if (!isset($email))
  { 
  echo "<form action=index.php method=post>";
  echo "<input type=text name=email>";
  echo "<br>";
  echo "<input type=submit value =OK>";
  echo "</form>";
  }

if (isset($email) ) echo $email;

if (!isset($email) ) echo "no";

/*mail($email,"WWW.38HQ.DE - NEWS -", "Danke Oskar \n du bist nun auf dem 38hq newsletter");*/
?>




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-01 08:52 UTC] jan@php.net
this is not a bug; bogus. please check http://www.php.net/release_4_2_0.php
 [2002-05-01 10:35 UTC] krizz at krizzbeatz dot de
Thanks for your help....but i cannot find something..its my first time doing PHP.....so...dont think i am crazy ..:-)

but can u give me an example how to solve this basic problem?
 [2002-05-01 10:39 UTC] jan@php.net
the bug system is not the apropriate place for support questions. mail php-general@lists.php.net for help.
A hint on your problem:
Substitute $email with $_POST['email']
 [2002-05-31 11:49 UTC] frayday at yahoo dot com
Remember that in php4.2 register_globals are turned off by default!

To access them you'll have to use $_GET[form_var_name] or
$_POST[form_var_name] or $_REQUEST[form_var_name]
.

I hope this helps !

David
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 18:01:24 2020 UTC