php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16931 undefined versioned symbol name
Submitted: 2002-04-30 12:43 UTC Modified: 2002-06-14 14:22 UTC
From: simon at the-earth dot com Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.2.0 OS: Solaris 8
Private report: No CVE-ID: None
 [2002-04-30 12:43 UTC] simon at the-earth dot com
Probelm compiling php 4.2.0  on solaris,
 ///////////// Configure  /////////////////

 ./configure --prefix=/usr/local \
  --with-apxs=/www/apache2/bin/apxs \
--enable-exif \
--enable-track-vars \
--with-calendar=shared \
--enable-safe-mode \
--enable-magic-quotes \
--enable-trans-sid \
--enable-wddx \
--enable-ftp \
--with-gd="/usr/local" \
--with-zlib \
--enable-gd-native-tt \
--with-t1lib="/usr/local" \
--with-jpeg-dir="/usr" \
--with-png-dir="/usr/local" \
--with-zlib-dir="/usr/local" \
--with-ttf \
--with-freetype-dir="/usr/local" \
 --with-openssl="/usr/local" \
 --enable-apc \
 --with-gettext="/usr" \
 --with-mysql=/usr/local 


////////////////// output error /////////////
/usr/local/sparc-sun-solaris2.8/bin/ld: .libs/libphp4.so: undefined versioned symbol name des_encrypt1@@SUNWprivate_1.1
/usr/local/sparc-sun-solaris2.8/bin/ld: failed to set dynamic section sizes: Bad value
collect2: ld returned 1 exit status
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/export/home/simon/Apachetoolbox-1.5.56/src/php-4.2.0'
make: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-30 13:21 UTC] simon at the-earth dot com
When I removed the ssl it worked ok!
 [2002-04-30 17:32 UTC] sniper@php.net
This is not exactly bug in PHP but in openssl.
Which version do you have installed?

--Jani

 [2002-06-14 14:22 UTC] sniper@php.net
This bug has been fixed for OpenSSL 0.9.7 (due to be released soon, but beta1 is already available at www.openssl.org)


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 19:03:38 2021 UTC