php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16921 string overflow
Submitted: 2002-04-29 22:18 UTC Modified: 2002-06-06 06:07 UTC
From: dijo at sc dot rr dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 4.1.2 OS: Slackware linux 8
Private report: No CVE-ID: None
 [2002-04-29 22:18 UTC] dijo at sc dot rr dot com
In Aol instant messenger you can do QueryStrings in a link like so:

<a href="http://dijo.yi.org?name=John Doe">Site</a> and it doesnt add the %20 between the John and Doe .. 

so what happens is .. the name variable holds John and the $SERVER_PROTOCOL variable holds Doe HTTP /1.0

I didnt know if you wanted to call it an overflow or what.

A friend suggested that it was a bug, so i'm turning it in.

Thanks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-06 06:07 UTC] sander@php.net
This is not a bug in PHP but a bug in the client (Aol instant messenger in this case).
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 14:01:27 2019 UTC