php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16833 make file error1 during install of php
Submitted: 2002-04-25 17:19 UTC Modified: 2002-06-18 17:44 UTC
Votes:11
Avg. Score:4.6 ± 0.6
Reproduced:10 of 10 (100.0%)
Same Version:2 (20.0%)
Same OS:5 (50.0%)
From: vivienne dot gilmore at noaa dot gov Assigned:
Status: Closed Package: MySQL related
PHP Version: 4.2.0 OS: Solaris 8
Private report: No CVE-ID:
 [2002-04-25 17:19 UTC] vivienne dot gilmore at noaa dot gov
EMANTICS -I/export/home/sb/done/php-4.2.0/TSRM -g -O2  -c libmysql.c && touch libmysql.lo
In file included from libmysql.c:5:
global.h:136: parse error
In file included from libmysql.c:5:
global.h:498: parse error
In file included from libmysql.c:12:
m_string.h:205: parse error
make[4]: *** [libmysql.lo] Error 1
make[4]: Leaving directory `/export/home/sb/done/php-4.2.0/ext/mysql/libmysql'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/export/home/sb/done/php-4.2.0/ext/mysql/libmysql'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/export/home/sb/done/php-4.2.0/ext/mysql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/sb/done/php-4.2.0/ext'
make: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-25 21:59 UTC] sniper@php.net
This is most likely cause by the autoconf 2.52 used to
create the distribution configure. 

Please try replacing it with this one 

http://www.edin.dk/php/configure.gz

 [2002-05-01 01:34 UTC] rip at rippo dot org
I have same OS, PHP version, etc.

When using the posted configure script (from bug report) I get the following:

root@unknown:[rip/php-4.2.0]:70 Making all in Zend
make[1]: Entering directory `/export/home/rip/php-4.2.0/Zend'
/bin/sh ../libtool --silent --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../main   -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=280 -DUSE_EXPAT -I../TSRM  -g -O2 -prefer-pic -c -o zend_language_parser.lo `test -f zend_language_parser.c || echo './'`zend_language_parser.c
In file included from zend_compile.h:24,
                 from zend_language_parser.c:147:
zend.h:55: unix.h: No such file or directory
make[1]: *** [zend_language_parser.lo] Error 1
make[1]: Leaving directory `/export/home/rip/php-4.2.0/Zend'
make: *** [all-recursive] Error 1
 [2002-05-26 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-06-05 09:08 UTC] kai dot jendrian at peregrine dot com
Hello,

I got the same bug. My configure failed because configure could not build configtest.out. Solaris 8 does not come with a cc by default and I just had installed gcc.

The fix which did it for me was linking /usr/local/bin/gcc to /usr/local/bin/cc.

.kai
 [2002-06-08 23:18 UTC] manuka at nerdherd dot net
I get the same behavior with 4.2.1, with both gcc versions 3.1 and 2.95, as well as both Sun and GNU make.
 [2002-06-09 09:03 UTC] sniper@php.net
reopen. 

 [2002-06-12 20:24 UTC] skylord at sun dot com
Same behaviour over here on Solaris 8 with 4.2.0 and gcc 2.95. When using the alternate config script, make bails out with "my_getwd.c:62: #error "No way to get current directory".
 [2002-06-13 16:14 UTC] skylord at sun dot com
Solution :

This one really sucked. The parse errors are indeed related to the autoconfig version used. Here's what to do :
1) Save the configure script to configure.org, and run ./buildconf to recreate it. Make sure you have autoconfig, automake and libtool on your system.
2) Configure will now complete, but if make dies with a "No way to get current directory error" on my_getwd.c , you can remedy this by adding a "#define HAVE_GETWD" line to ext/mysql/libmysql/mysys_priv.h .
3) After that, make may sh*t itself again on a redeclaration of perror in dbug.c . This will go away if you save the original dbug.c to something else, and then put a new one in place in which you have deleted both instances of the perror declaration lines.

After all of this, PHP compiled OK on my box.

Dirk
 [2002-06-13 16:24 UTC] sniper@php.net
Please try this snapshot: 

http://snaps.php.net/php4-latest.tar.gz

 [2002-06-18 15:11 UTC] john dot hughes at ubs dot com
Ok, here's the fix for solaris 8 with gcc.

install m4
install autoconf
cd php-4.2.1 src directory
run autoconf

Once that is done, everything should ./configure, make, make install just fine.

As far as I can tell the 4.2.1 release is jacked because of a bad autoconf prior to packaging. 

John
 [2002-06-18 17:44 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 [2002-06-19 17:49 UTC] james at jgj dot org dot uk
Hello,

I have the same problem, using php 4.2.1 - the new 
configure script didn't fix it, it still dies in the same 
way. I am using GCC as supplied with Solaris 8 OE 2002/02 
Sparc, on that platform... it is a 64 bit host if that 
helps in some way.

thanks,

James
 [2002-06-19 18:12 UTC] james at jgj dot org dot uk
Hello,

I have the same problem, using php 4.2.1 - the new 
configure script didn't fix it, it still dies in the same 
way. I am using GCC as supplied with Solaris 8 OE 2002/02 
Sparc, on that platform... it is a 64 bit host if that 
helps in some way.

thanks,

James
 [2002-06-19 18:14 UTC] james at jgj dot org dot uk
Hi,

First: Sorry for the double submission earlier :)

Second: i had tried running ./buildconf - it didn't fix it. 
But upgrading to autoconf 2.53 then running ./buildconf 
did.

thanks all,

James
 [2002-06-22 08:12 UTC] bm at ioo dot prv dot pl
Well, here's a piece of installation on my Solaris8 i386:

> cd php4-STABLE-200206220300
> ./configure --with-apxs=/usr/apache/bin/apxs --with-java=/usr/java --with-mysql
> make
Making all in Zend
make[1]: Entering directory `/tmp/src/php4-STABLE-200206220300/Zend'
yacc -p zend -v -d ./zend_language_parser.y -o zend_language_parser.c
"./zend_language_parser.y", line 47: fatal: invalid escape, or illegal reserved word: pure_parser
make[1]: *** [zend_language_parser.c] Error 1
make[1]: Leaving directory `/tmp/src/php4-STABLE-200206220300/Zend'
make: *** [all-recursive] Error 1


greetings,
bm.
 [2002-07-02 04:33 UTC] ab at nospam dot please at oz dot org
I'm a solaris person regularly required to configure
and build GNU software, and I keep a repository
of scripts to get configure to do the right thing

I try to avoid symlinking cc to gcc as some 
environments insist on a sun compiler ($$$)
and its nice not to have to re-hack things for
a new client.

While there is indeed a bug in the php configure
script,

$ CC=gcc ./configure

is sufficient in this and most other cases.
 [2002-11-19 16:08 UTC] glennz928 at yahoo dot com
I'm getting the error 

my_getwd.c:62: #error "No way to get current directory"

I am compiling php-4.2.3.
I'm on a solaris 7 box with autoconf 2.53, with gcc-2.95.3.

Any suggestions?
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 16:02:22 2014 UTC