php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16808 Unresolved symbol: __umoddi3 (code)
Submitted: 2002-04-24 16:27 UTC Modified: 2002-05-07 19:36 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: pbriggs at clinitech dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: HPUX 11.00
Private report: No CVE-ID: None
 [2002-04-24 16:27 UTC] pbriggs at clinitech dot net
HP-UX 11.00
Binutils 2.12
GCC 3.0.4
GNU Make 3.79.1

mysql-3.23.49 (using GCC)
./configure --prefix=/opt/mysql

Have verified -lgcc being used in mysql build.

apache-2.0.35 (using GCC)
./configure --prefix=/opt/apache2

php-4.2.0 (using GCC)
./configure --prefix=/opt/php --enable-libgcc \
--with-apxs2=/opt/apache2/bin/apxs \
--with-mysql=/opt/mysql --enable-sockets

Start Apache:
/opt/apache2/bin/apachectl start

Error:
Syntax error on line 217 of /opt/apache2/conf/httpd.conf:
Cannot load /opt/apache2/modules/libphp4.so into server: Unresolved symbol: __umoddi3 (code)  from /opt/mysql/lib/mysql/libmysqlclient.sl.10
/opt/apache2/bin/apachectl start: httpd could not be started

Everything has been compiled with GCC.  Have used -enable-libgcc in PHP's compiling, but somehow I'm still having problems with this __umoddi3 not being resolvable.

Patrick

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-07 19:36 UTC] aaron@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php

This looks like a gcc problem. I've diagnosed problems
with Solaris+gcc where gcc will include libgcc symbols
in the object files but fails to tell the native linker
(/usr/ccs/bin/ld on solaris) how to resolve those
symbols. Therefore at runtime you get symbol resolution
failures.

Do you really have a shared version of libgcc? If so,
is it in your library path?

To link against libgcc.a statically, and as a minor
workaround (since this is partly gcc's fault), try this:

LDFLAGS="`gcc -print-libgcc-file-name`" ./configure --your-flags

If you are still having this problem, please open a bug
with mysql, as the unresolved symbol is coming from that
object. Thanks for using Apache and PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC