php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16797 argc/argv in $_SERVER?
Submitted: 2002-04-24 11:18 UTC Modified: 2002-04-24 19:18 UTC
From: pete at mdsc dot com Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.2.0 OS: Linux RedHat 7.2 i386
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pete at mdsc dot com
New email:
PHP Version: OS:

 

 [2002-04-24 11:18 UTC] pete at mdsc dot com
After turning off register_globals in PHP 4.2.0, the behavior of register_argc_argv is not what I expected.  When using the CGI SAPI, and setting register_globals to Off and register_argc_argv to On, the argc and argv values are only available in the $_SERVER array.  It seems to me that they should be in $GLOBALS.  Is this the intended operation?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-24 19:18 UTC] yohgaki@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 21:01:24 2020 UTC