|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16748 Apache 2.0.36_dev fails to start after installingen PHP module
Submitted: 2002-04-23 06:57 UTC Modified: 2002-04-24 16:05 UTC
From: remy at planet dot nl Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: linux
Private report: No CVE-ID: None
 [2002-04-23 06:57 UTC] remy at planet dot nl
I've tried to install PHP 4.2 and PHP 4.3_dev with Apache 2.0.36_dev. But after the installation the PHP module will not start. One of the stange things is, if I start apache without the PHP module and after that I do a restart with the PHP module, the PHP module will work for a park. Sessions will not work.

Remy Stibbe


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-23 06:59 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

 [2002-04-24 14:09 UTC] JuergenNagel at web dot de
I also got the problem with Apache 2.0.35 not starting up when having the PHP module activated.

I compiled PHP 4.2.0 with the following options:
--enable-safe-mode --enable-gd-native-ttf --enable-inline-optimization --with-apxs2=/usr/apache2/bin/apxs --with-bz2 --with-zlib --with-cyrus --with-dom --with-dom-xslt --with-gd=/usr/src/gd-2.0.1 --without-mysql --with-pgsql=/opt/pgsql --prefix=/usr --with-openssl --enable-calendar --enable-ftp --enable-gettext=shared --with-jpeg-dir=/usr --with-png-dir=/usr --with-freetype-dir=/usr

The strange thing is, that there isn't any error message. Neither on the console nor in the logfiles.

When I deactivate the PHP module the error_log says:
[Wed Apr 24 19:44:55 2002] [notice] suEXEC mechanism enabled (wrapper: /usr/apache2/bin/suexec)
[Wed Apr 24 19:44:55 2002] [notice] Apache/2.0.35 (Unix) DAV/2 configured -- resuming normal operations

When I activate the PHP module the error_log says:
[Wed Apr 24 19:51:51 2002] [notice] suEXEC mechanism enabled (wrapper: /usr/apache2/bin/suexec)

The Apache server just doesn't start.
Why? :-)
 [2002-04-24 16:05 UTC] remy at planet dot nl
I've just compiled PHP with --enable-debug and PHP worked except the cookies (mentioned in another bugreport).
 [2002-04-25 20:58 UTC] dharana at dharana dot net
Apache 2.0.35 + PHP 4.2.0 on Debian linux produced the same effect. Apache+php module won't start without the 'restart' trick.

apache configuration: ./configure --enable-module=so
php configuration: ./configure --with-apxs2=/usr/local/apache2 --without-pear
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 07:01:31 2024 UTC