php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #16705 SASL support with LDAP
Submitted: 2002-04-19 15:16 UTC Modified: 2007-10-06 02:27 UTC
Votes:15
Avg. Score:4.6 ± 0.7
Reproduced:9 of 9 (100.0%)
Same Version:4 (44.4%)
Same OS:1 (11.1%)
From: quinn at quinnperkins dot com Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 4.1.2 OS: OS X 10.1.4
Private report: No CVE-ID:
 [2002-04-19 15:16 UTC] quinn at quinnperkins dot com
PHP's LDAP features do not support SASL authentication. 
Since this is a key element of LDAPv3, it would be nice to 
implement something similar to the support in Perl 
(Auth::SASL).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-19 22:04 UTC] sniper@php.net
reclassified

 [2002-06-21 15:50 UTC] venaas@php.net
Yes, it would be nice. Maybe you or someone else would
like to implement it...

I might do it later sometime perhaps, but I don't see it
happening in the near future.
 [2004-03-08 10:01 UTC] andreas at conectiva dot com dot br
Isn't this already fixed in bug #24084?
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 19:01:53 2014 UTC