php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16698 phpinfo() hangs
Submitted: 2002-04-19 10:28 UTC Modified: 2002-06-11 14:30 UTC
From: spoon at nexdot dot net Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.0 OS: Windows XP Pro
Private report: No CVE-ID: None
 [2002-04-19 10:28 UTC] spoon at nexdot dot net
a php file containing nothing but:

<?

phpinfo();

?>

loads about halfway, then stops. the server running php+apache then goes into 5 second "freezes" and 5 second 100% usage peaks. These happens consistantly and hoses the system untill all other processes cant function.

The error logs show nothing, and the event viewer (windows)shows nothing. It also happens when i use:

show_source("php_script.php");

on a fairly small script.

I am using the Apache2filter test module.

I can't currently show you an example of this becuase: my server just went down, and im at work (it's at home) and it would crash if i showed you! When i get home i will recreate the bug a 3rd time to make sure im not crazy.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-21 18:56 UTC] spoon at nexdot dot net
From reading other bugs about corrupted output on XP systems, i tried one of the WORK AROUNDS that do not fix the problem, but hide it (which is good enough for me untill an actual fix is found).

I did the suggested (and disputed by php.net) method of having the content gzipped. It does HIDE the problem (in their bug and in mine). But like php.net said, it is not recomended.

phpinfo() does not hang, and i have no corrupted output, with gzip on.
 [2002-05-17 03:34 UTC] jwoolley@php.net
I'm having trouble reproducing this problem on Linux, with either the threaded or non-threaded MPMs.  (Yes, I know you said you saw it on WinXP.)  Can you generate a backtrace on this somehow?  Interrupt the httpd task that's running out of control with MSVC's debugger and find out what it's up to?  (Sorry I can't be much more specific on this, I don't know much about MSVC.)  I assume you read 
http://www.apache.org/dist/httpd/binaries/win32/#xpbug , right?

Thanks,
Cliff
 [2002-05-17 06:05 UTC] spoon at nexdot dot net
Yes, i read about the bug.

Since my original posts, i have upgraded to the non-beta (stable) PHP 4.2 and using the expirimental modules. No problems since.
 [2002-06-11 14:30 UTC] sander@php.net
Ah, this seems to be fixed then. Let's close this one.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Feb 20 16:01:26 2019 UTC