php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1669 using path info data in an URL chokes PHP on WinNT/Apache
Submitted: 1999-07-06 11:24 UTC Modified: 2002-06-16 08:32 UTC
From: gordon+phpbug at vip dot fi Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 3.0.11 OS: Windows NT (4.0SP5)
Private report: No CVE-ID: None
 [1999-07-06 11:24 UTC] gordon+phpbug at vip dot fi
On Windows NT with PHP 3.0.11 on Apache 1.3.6 when using an URL
with path info data, PHP chokes and tells that it could not open the
input file. like this:

http://localhost/test.phtml/path/info/is/here

The path info data should go into the PATH_INFO variable (on Unix versions
the path info is parsed correctly from the URL).

I am sure that this has to do with the way PHP has to be installed on WinNT
(ScriptAliasing etc.) so there might not be a solution. This is not a bug per se,
but relevant to some developers (e.g. someone might be using PATH_INFO
instead of using HTTP GET variables to keep track of states etc.).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:32 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 01:03:38 2021 UTC