php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16682 strange infinite loop problem where no infinite loop exists
Submitted: 2002-04-18 10:50 UTC Modified: 2002-04-18 11:30 UTC
From: carl at topthetable dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.2.0 OS: Mac OS X
Private report: No CVE-ID: None
 [2002-04-18 10:50 UTC] carl at topthetable dot com
The problem is that the below script entered an infinite 
loop, only stopping when the when the time_limit kicks in.

It's problem is caused by this script

<?
  for ( $i=1; $i<=11; $i++ ) {
    $a = "Position".$i;
  }
?>

It doesn't happen on 4.1.1 CLI version, and unfortunately, 
I don't have access to any other versions at the moment.

This is my configure line :

'./configure' '--with-mysql' '--with-gd=/usr/local' '--
with-png-dir=/sw' '--with-jpeg-dir=/sw' '--with-apxs' '--
with-zlib-dir=/sw' '--with-freetype-dir=/sw' '--with-curl=/
sw' '--with-t1lib=/usr/local' '--enable-ftp' '--enable-
mbstring' '--enable-mbstr-enc-trans' '--with-xml'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-18 11:30 UTC] carl at topthetable dot com
My bad - It was a problem with the auto_prepend_file that 
someone stealthly added to my config, sorry about that!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 19:03:36 2022 UTC