php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16641 PHP does not like Norwegian letters
Submitted: 2002-04-16 13:24 UTC Modified: 2002-09-30 20:31 UTC
From: brr at brr dot no Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 OS: Windows XP
Private report: No CVE-ID: None
 [2002-04-16 13:24 UTC] brr at brr dot no
Server error!
Error message: 
couldn't create child process: 22: C:/WEB/php4win/php.exe 
If you think this is a server error, please contact the webmaster 
Error 500
brr2 
04/16/02 19:13:40 
Apache/2.0.35 (Win32) 

Path: http://brr2/moregroupware060/contact/index.php?PHPSESSID=7be060e8f0b91476a48e4b4bd13d594d&action=alphab&list=?



The latest PHP versions does not like Norwegian letters (??? and ???). I am running a PHP application called Moregroupware (www.moregroupware.org) on my Windows XP computer with Apache/2.0.35/Windows and PHP/4.2.0 RC4. 

I did not have this problems with earlier versions of PHP, e. g. 4.1.2 together with Apache/1.3.24.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-17 00:37 UTC] sniper@php.net
Apache2 support is still experimental. Do you get
same problem with Apache 1.3.24 and 4.2.0RC4 ?


 [2002-04-17 01:51 UTC] brr at brr dot no
Ok. I have testet a little bit more. 

I do not get the bug if I use Apache 1.3.24/Windows together with PHP 4.2.0RC4/Windows. So the problem only appears with the combination of Apache/2.0.35/Windows together with PHP/4.2.ORC4/Windows.

But even more strange: I only get the problem when I use Internet Explorer. If I use Mozilla browser or Opera I do not get it. Strange!
 [2002-04-18 09:19 UTC] sniper@php.net
reclassified.
 [2002-06-11 14:28 UTC] sander@php.net
This might as well be a bug in the character-set-handling-stuff of Apache 2 due to incorrect or strange headers sent by Internet Explorer. 
 [2002-09-30 20:31 UTC] iliaa@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

Browser issue.
 [2002-10-03 19:44 UTC] elfrito at antisocial dot com
at least in Apache 2.x, in httpd.conf file, change:

AddDefaultCharset ISO-8859-2

to

AddDefaultCharset ISO-8859-1

It works for me.

By the way, if you call a simple and plain html file (no .php) your letters look strange too, my conclusion: this is not a php bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 01:03:34 2021 UTC