php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16631 Only one (last?) cookie send to browser
Submitted: 2002-04-16 06:56 UTC Modified: 2002-05-17 07:52 UTC
Votes:2
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: herbert at groot dot jebbink dot nl Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.0CVS-2002-04-1 OS: Linux 2.2.14
Private report: No CVE-ID: None
 [2002-04-16 06:56 UTC] herbert at groot dot jebbink dot nl
Test php script.

    <?php

      setcookie('abc', 'abc', time() + (60 * 60 * 24 * 365), '/');
      setcookie('xyz', 'xyz', time() + (60 * 60 * 24 * 365), '/');

      echo "Hallo World \n\n";

    ?>

Respons with Apache 2.0.35 / PHP 4.2.0 RC4

    HTTP/1.1 200 OK
    Date: Tue, 16 Apr 2002 09:45:03 GMT
    Server: Apache/2.0.35 (Unix) PHP/4.2.0RC4
    Accept-Ranges: bytes
    X-Powered-By: PHP/4.2.0RC4
    Set-Cookie: xyz=xyz; expires=Wed, 16-Apr-03 09:45:04 GMT; path=/
    Connection: close
    Content-Type: text/html
    X-Pad: avoid browser bug

Respons with Apache 1.3.22 en PHP 4.0.6

    HTTP/1.1 200 OK
    Date: Tue, 16 Apr 2002 09:49:55 GMT
    Server: Apache/1.3.22 (Unix) PHP/4.0.6 mod_ssl/2.8.5 OpenSSL/0.9.6b
    X-Powered-By: PHP/4.0.6
    Set-Cookie: abc=abc; expires=Wed, 16-Apr-03 09:49:56 GMT; path=/
    Set-Cookie: xyz=xyz; expires=Wed, 16-Apr-03 09:49:56 GMT; path=/
    Connection: close
    Content-Type: text/html

Greetings, Herbert

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-17 15:04 UTC] sander@php.net
Dupe of #16626
 [2002-05-17 07:52 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 23:03:39 2021 UTC