php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16604 Apache 2 hangs with RC4
Submitted: 2002-04-14 17:31 UTC Modified: 2002-04-21 17:46 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: veb at freemail dot it Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.0 RC4 OS: WinXP
Private report: No CVE-ID: None
 [2002-04-14 17:31 UTC] veb at freemail dot it
Running PHP 4.2.0 RC4 (php-4.2.0RC4-win32.zip 14-Apr-2002 14:18) on Apache 2.0.35 I got this error:

C:\Internet\Apache Group\Apache2\bin>apache

apache: module "C:\home\php\php4\SAPI\APACHE2FILTER\sapi_apache2.c" is not compatible with this version of Apache.
Please contact the vendor for the correct version.

But my module load row is:

LoadModule php4_module C:/Sviluppo/php/experimental/apache2filter.dll

RC3 was OK...
I have no modules loaded in PHP and I've updated the php4ts.dll in the winnt/system32 dir.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-14 17:37 UTC] veb at freemail dot it
Corrected the version
 [2002-04-21 17:46 UTC] jwoolley@php.net
This is not a bug. Please double-check the documentation available
at http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This is what happens if you try to run an Apache DSO with a version of Apache that doesn't match it.  Make sure the Apache headers you're using to compile PHP match the version of Apache you're using, and make sure that the .DLL was recompiled against the same version, and then it will work.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 06:03:16 2021 UTC