php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16601 php_bz2.dll won't load
Submitted: 2002-04-14 17:14 UTC Modified: 2002-06-28 11:05 UTC
From: norny at yahoo dot com Assigned:
Status: Closed Package: Bzip2 Related
PHP Version: 4.2.0RC4 OS: Windows 2000
Private report: No CVE-ID:
 [2002-04-14 17:14 UTC] norny at yahoo dot com
I tried just to load all the extensions in 4.2.0RC4. I get a popup notice that says php_bz2.dll can't be found even though it's in the same directory with all the other extensions that load fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-14 18:34 UTC] sniper@php.net
Is that file from the same package or is it some old dll?

 [2002-04-14 18:37 UTC] sniper@php.net
And have you replaced php4ts.dll with the one found in the 
RC4 package? And do some other extensions load? which ones?
have you copied the bundled dlls from the package?

http://www.php.net/manual/en/install.windows.php#install.windows.extensions


(And please don't open multiple bug reports about same issues)


 [2002-04-14 19:10 UTC] norny at geocities dot com
It is from the same package and I did replace the old 4.1.1 php4ts.dll with the one in the 4.2.0RC4 package. ctype, db, dbase, dbx, filepro, hyperwave, mbstring, shmop, sockets, tokenizer, and w32api are the ones that load without error.
 [2002-04-14 19:18 UTC] norny at yahoo dot com
I'm not sure if it helps, but I click the OK button for the error message on a phpinfo() page once for php_bz2.dll, once for php_interbase.dll, and once for php_mssql.dll, then I have to go again for another round of clicking OK, but with clicking twice for each extension.
 [2002-04-14 19:25 UTC] sniper@php.net
Are you running PHP as CGI or some webserver module?
And if the latter, which webserver and version?
Are you sure you have really replaced the correct php4ts.dll? And that you don't have some older one laying
around somewhere? Tried booting yet? :)

 [2002-04-14 19:38 UTC] norny at yahoo dot com
It's a CGI to Apache 1.3.22.

I have php4ts.dll in two places according to a windows file search, C:\winnt and c:\winnt\system32. I tried also keeping it with php.exe and tried without. Same result.
 [2002-04-14 19:45 UTC] norny at yahoo dot com
I went on a limb and rebooted. No change. Errors remain.
 [2002-04-14 19:48 UTC] norny at yahoo dot com
The 'expose_php' header also appears in the regular page output for phpinfo() when there's an error popup.

X-Powered-By: PHP/4.2.0RC4 Content-type: text/html
 [2002-04-14 19:53 UTC] imajes@php.net
it seems you have conflicting php4ts.dll's.

I suggest you remove all of the files you had during install, and start again. This is probably the easiest method of trying it out.

as far as i can see, that module loads fine for me.
 [2002-04-14 20:13 UTC] norny at yahoo dot com
I rolled up all my stuff for previous versions of php into one big zip file so I could have only 1 php4ts.dll on my system, located in c:\winnt\system32. Then I did a file search for php4ts.dll to double check. The filesize of the php4ts.dll in my directory is 1,028,096 bytes with a md5 hash of 52d05cf883b6e0410add9e15b2352f7b.

Then I did a search for php* in c:\winnt and it found php4ts.dll and php.ini. I still get errors for bz2, interbase, and mssql.
 [2002-04-14 20:22 UTC] norny at yahoo dot com
I'm just trying to make sure we're talking about the same files.

Md5 hashes of the extensions:
1c9a9f9ae388b133dbeab61063815948 *php_bz2.dll
61d87a3f4ec9422ee9e20b56ab2b3b43 *php_ctype.dll
6e09ae3bc21c4cc728aa782d9234dde2 *php_db.dll
22645ae3539be2772a07e043dbe190c2 *php_dbase.dll
26f38f936ed167b8fc5708188df7e766 *php_dbx.dll
dc5870f7c29b9f7df69319faea1303cb *php_exif.dll
19bcf59e0d961de84a15da848b35b151 *php_filepro.dll
91678442412c2a4518843df3306f2220 *php_hyperwave.dll
bed398dccac4ff7d38f93c8c9e7ff5c8 *php_interbase.dll
776f46de368bb1d73fa1cdb771375ab6 *php_mbstring.dll
8d56fd8a95be55b8ff2e457a1b4d0a0b *php_msql.dll
585cfb220aab52b6b2f449ae7ce18c6c *php_mssql.dll
d7b11b5c22cd81b7b4fbf1f66197ee12 *php_shmop.dll
224ece12a772b6644e72fc8a082d9e4e *php_sockets.dll
cc4edd5f195184b276d5dc8f6766a9b0 *php_tokenizer.dll
0282c8433060d40285b0b17dd7b077d2 *php_w32api.dll

75b316bbeea00450120f0202b6f50bc1 *php-cli.exe
98651ce0e734f67c75be03f44a7ab39b *php.exe
a8ce4d9eeba45b6b4e38df24fb778c41 *php.ini-dist
9725886dbee0c3cb820146d75563cb8a *php.ini-recommended
93bb56a327068002f2ce96e991d9ce62 *php4ts.lib

52d05cf883b6e0410add9e15b2352f7b *php4ts.dll
 [2002-04-15 12:23 UTC] jtate@php.net
Dll's won't load if the dll's that it depends on aren't in the path.  Use the dependency walker that comes with Vis Studio to see what you're missing.  Same with the php_mssql.dll or whatever bug you reported with this one.  This should be documented IMO.
 [2002-04-15 17:17 UTC] norny at yahoo dot com
I resolved the interbase and mssql issues with the comment from jtate, but I still can't get bz2 to load without error.

qa.php.net also mentions a xslt dll. I haven't seen one in the 4.2.0RC4, but I have seen sablot.dll and expat.dll that would go with it.
 [2002-04-15 17:42 UTC] norny at yahoo dot com
I went on another limb and tried seeing if the same error appeared using the php4apache.dll module. Same thing happens, but just when apache is starting, not during every execution of a script. No suprise.
 [2002-06-28 03:31 UTC] cynic@php.net
ISTR php_bz2.dll depends on libbz2.dll or something like that. Are you sure this is not what bites you?

 [2002-06-28 11:05 UTC] norny at yahoo dot com
4.2.1 works.
 
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Mon Jun 15 18:01:54 2015 UTC