php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16596 Rlative directory problems in XSL files (xslt extension with Sablotron)
Submitted: 2002-04-14 04:23 UTC Modified: 2002-07-08 03:39 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ruudb at stress dot utwente dot nl Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.3.0-CVS OS: Linux 2.4.18
Private report: No CVE-ID: None
 [2002-04-14 04:23 UTC] ruudb at stress dot utwente dot nl
When using PHP 4.2.0RC3 with Apache 2 filter, the current directory seems to be set to / instead of the directory where the script resides (however, system("pwd); returns the correct current directory).

This breaks an XML/XSL oriented website: entries in the XSL files like "<xsl:include href="file://../../xsl/html/all.xsl" />" do not work anymore. 

The problem does _NOT_ appear with the RC3 when using the Apache 1.3 DSO or Static SAPI in conjunction with Apache 1.3.22, but only when using the apache2filter. The versions used are Apache 2.0.35 and PHP 4.2.0 RC3. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-14 04:32 UTC] derick@php.net
Fix version
 [2002-04-15 05:22 UTC] ruudb at stress dot utwente dot nl
The same problem occurs while using the fopen() function with relative paths

(also in RC4)
 [2002-04-19 11:24 UTC] aaron@php.net
I don't see how this is related to the apache2filter,
since that module makes no assumptions about paths
or current working directories. Perhaps I misunderstand
the assumptions that Sablotron is expecting, please
advise.
 [2002-04-19 12:12 UTC] ruudb at stress dot utwente dot nl
sent example script with xsl files that reproduce the problem to aaron and sterling by e-mail
 [2002-07-07 21:05 UTC] sniper@php.net
Any updates on this one? 
Does it happen with latest CVS of Apache and PHP ?

 [2002-07-08 03:39 UTC] ruudb at stress dot utwente dot nl
Problem is fixed with latest CVS of Apache and PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 22:03:37 2021 UTC