php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16575 cannot load php4apache.dll with apache2
Submitted: 2002-04-12 14:10 UTC Modified: 2002-04-12 15:57 UTC
From: Markus_Heiden at public dot uni-hamburg dot de Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.1.2 OS: Windows XP Professional
Private report: No CVE-ID: None
 [2002-04-12 14:10 UTC] Markus_Heiden at public dot uni-hamburg dot de
I am not able to load the php4apache.dll with apache2, it only says 

Syntax error on line 173 of E:/Apache2/conf/httpd.conf:
Cannot load E:/php/sapi/php4apache.dll into server:
Das angegebene Modul wurde nicht gefunden.

but the module if definitly there and all other dlls are copied like the doku said. Where can I get php error output in such cases (there is nothing in the apache logs)?

BTW others (from a newsgroup) seem to have the problem too, but still no solution...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-12 15:57 UTC] cmk@php.net
You can't load the Apache 1 sapi into Apache 2.

You have to load apache2filter.dll.

Grab PHP 4.2.0 RC3, which will include the file you need.
 [2002-04-26 16:44 UTC] luna at enst dot fr
If it can help, I tried to make an installation doc at:
http://137.194.8.83/ATSEC/PHP4Apache2Windows.html
 [2003-02-18 18:40 UTC] anterfire at hotmail dot com
copy php4ts.dll to apache2/bin/ will be ok.
 [2003-05-01 16:26 UTC] jcrutchf at yahoo dot com
I had this same error on a Windows 2000 advanced server box, running Apache 2 and PHP 4.3.1.  I was able to fix it by doing the following, quoted from _Sams Teach Yourself PHP, MySQL and Apache in 24 Hours_, page 51:

"1. In the PHP installation directory, find the php.ini-dist file and rename it php.ini.
2.  Move the php.ini file to C:\WINDOWS\ or wherever you usually put your *.ini files.
3.  Move the php4ts.dll file to C:\WINDOWS\SYSTEM\ or wherever you usually put your *.dll files."

Substituting C:\WINNT\* for C:\WINDOWS\*, Apache 2 started right back up, no reboot required.
 [2003-12-25 19:26 UTC] bennesantana at terra dot com dot br;bene at igc dot com dot b
This mistake is linked to the computer in use.  
  
In my case  
Computer 1 ATHON 2600+ 256Mb 40Gb ATI 128Mb, Motherboard ASUS A7N8X-X. he doesn't get to find php4apache.dll   
Windows Home Edition  
Apache 1.3.28  
PHP 4.3.2  
  
Computer 2 CELERON 1.7Mhz 128Mb 40Gb Gforce4 64Mb, works without some problem.  
Windows Home Edition    
Apache 1.3.28    
PHP 4.3.2    
  
Attention: Httpd.conf are same in the two computers. Please describe their computers, where this mistake, the windows happens autom?ticamente is not updated. (0x800A138F)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 10:01:24 2019 UTC