php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16567 out parameters unchanged in PHP
Submitted: 2002-04-12 07:22 UTC Modified: 2002-04-27 05:53 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: fvaletas at mapstan dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.1.1 OS: Windows 2000
Private report: No CVE-ID: None
 [2002-04-12 07:22 UTC] fvaletas at mapstan dot com
Calling a method with a parameter declared as out in automation (ex: [out] long *code) doesn't update the PHP variable.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-27 05:53 UTC] phanto@php.net
you have to wrap the value into a variant object. see http://www.php.net/variant
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 05:05:45 2022 UTC