php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16518 undefined symbol: stat
Submitted: 2002-04-09 15:35 UTC Modified: 2003-02-26 09:16 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: mitch at youngfamily dot org Assigned:
Status: Closed Package: Informix related
PHP Version: 4.0CVS-2002-04-09 OS: RedHat 7.2 / Debian 3.0
Private report: No CVE-ID: None
 [2002-04-09 15:35 UTC] mitch at youngfamily dot org
I have successfully got apache-2.0.35 & php4.2-CVS to work fine together, but when I recompile php with informix support it compiles fine but when 

I try to start apache2 I get the folloing message.
 
[root@redhat bin]# ./apachectl start
Syntax error on line 217 of /usr/local/apache/conf/httpd.conf:
 Cannot load /usr/local/apache/modules/libphp4.so into server: /opt/informix/lib/esql/libthgen.so: undefined symbol: stat
./apachectl start: httpd could not be started
[root@redhat bin]#


It appears to be a problem with the latest version of the Informix CSDK 2.70 because I downgraded to 2.60 and everything compiled and runs fine after the downgrade!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-15 20:42 UTC] sniper@php.net
This snapshot _should_ fix the problem:

http://snaps.php.net/php4-latest.tar.gz

It works fine for me with the 2.70.UC3 which is the latest I found from the informix site.

--Jani

 [2002-07-16 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-10-01 08:37 UTC] fish at iface dot co dot uk
I can confirm that it's an Informix problem - got identical error running make test while building DBD-Informix 1.00.PC2
 [2003-02-26 09:16 UTC] nobbie@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug: #13655
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 08:01:31 2024 UTC