php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16489 php_admin_value not allowed in virtualhost
Submitted: 2002-04-08 07:06 UTC Modified: 2002-05-17 01:23 UTC
Votes:12
Avg. Score:4.8 ± 0.4
Reproduced:12 of 12 (100.0%)
Same Version:5 (41.7%)
Same OS:3 (25.0%)
From: phpbug at spambox dot dk Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.1 OS: All
Private report: No CVE-ID: None
 [2002-04-08 07:06 UTC] phpbug at spambox dot dk
I upgraded from Apache 1.3.24 to 2.0.35

Apache is configured with:
./configure  --prefix=/usr/local/apache2 --enable-mods-shared=all --enable-ssl --mandir=/usr/local/man

PHP is configured with:
./configure --with-mysql=/usr/local/mysql --with-gd=/usr/local --with-t1lib --with-jpeg-dir --with-png-dir --with-tiff-dir --with-zlib-dir --with-freetype-dir=/usr/local/include/freetype2/freetype --with-imap --with-gettext --with-zlib --with-pdflib --enable-exif --enable-ftp --enable-bcmath --with-mcrypt --with-dom --with-expat-dir=/usr/local --enable-xslt --with-xslt-sablot --enable-sablot-errors-descriptive --with-config-file-path=/usr/local/etc --with-tsrm-pth --with-apxs2=/usr/local/apache2/bin/apxs

I have a virtual host like this in my httpd.conf:
-- cut
<virtualhost 192.168.1.3>
 Servername www.domain.dk
 Serveralias domain.dk
 DocumentRoot /home/freakcers/www/www.domain.dk
 ErrorLog /home/freakcers/logs/www.domain.dk/error.log
 CustomLog /home/username/logs/www.domain.dk/access.log combined

 php_admin_value open_basedir /home/username/www:/usr/local/lib/php

 <Directory /home/username/www>
  Options ExecCGI Includes FollowSymLinks
  AllowOverride All
  Order Deny,Allow
  Allow from all
 </Directory>
</virtualhost>
-- cut

If i run "apachectl configtest" i get this error:
Syntax error on line 10 of /usr/local/apache2/conf/virtualhosts/domain.dk.conf:
php_admin_value not allowed here


If you need any futher details, please advice :-)

Best regards Henrik Larsson

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-08 16:10 UTC] phpbug at spambox dot dk
The virtual host is included from httpd.conf with the include statement.

It is not directly in httpd.conf
 [2002-04-14 10:13 UTC] phpbug at spambox dot dk
Problem still exists in 4.2.0 RC3.
 [2002-04-14 19:30 UTC] phpbug at spambox dot dk
Problem still exist in 4.2.0 RC4.
 [2002-04-14 19:36 UTC] sniper@php.net
..and will most likely also exist in the actual release.
Apache2 support in it will still be experimental.


 [2002-04-15 18:19 UTC] yllar at nss dot ee
When can we expect this fixed?
 [2002-04-25 10:48 UTC] samm at os2 dot ru
I tried this on OS/2 apache2 and Win32 apache2. PHP 4.2 Release. Bug still exist :( I can`t swith to apache2 now :(
 [2002-04-25 17:07 UTC] phpbug at spambox dot dk
Problem still with 4.2.0 release.
Updated version.
 [2002-05-17 01:23 UTC] jwoolley@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

I just applied a patch for this.  Thanks for the report!

The patch is at http://cvs.php.net/diff.php/php4/sapi/apache2filter/apache_config.c?r1=1.20&r2=1.21&ty=u
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 09:01:23 2021 UTC