php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16465 Feature Request
Submitted: 2002-04-06 13:50 UTC Modified: 2002-04-06 19:09 UTC
From: dulcis28 at hotmail dot com Assigned:
Status: Not a bug Package: *Database Functions
PHP Version: 4.1.2 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dulcis28 at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-04-06 13:50 UTC] dulcis28 at hotmail dot com
Hi,

This is NOT a bug, but I couldn't find a place to request a feature.
I am creating a php page that have database related functions.  It's a database abstraction function. Thus I would call my custom made functions for any php database function.  Thus, I can change from a MySQL database to Oracle, without changing any php code in my files.  all i have to do is to set one variable to which database i want to use.  i would like php to create an abstacted php database function.....instead of having so many php functions for each database, just have one and then set a variable to what database to use....yes, i could use ODBC, but it's not good.

thanks.

please let me know if this is a good feature request.

thanks. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-06 13:54 UTC] mfischer@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php


 [2002-04-06 19:09 UTC] rasmus@php.net
There is a DB abstraction layer in pear.  It ships with PHP.  Poke around a bit, you will find it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 19:01:16 2020 UTC