|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16419 Mysql multiple Insert fails...
Submitted: 2002-04-04 02:51 UTC Modified: 2002-04-04 04:15 UTC
From: dhaval_adams at yahoo dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0CVS-2002-04-04 OS: Linux redhat 7.2
Private report: No CVE-ID: None
 [2002-04-04 02:51 UTC] dhaval_adams at yahoo dot com
hi this is my script and it fails when I run it. Sometimes the first one works and some times the second one..however if I run 1 by 1 both of them work but if I run themn in the same script..It fails..

	$connect = mysql_pconnect($dbhost, $dbuser, $dbpass);

	$query = "INSERT INTO transactions (fromid,toid,threadid,messageid,timesent,message,subject,new,unread) VALUES ('$username','$toid','$threadid','$messageid',now(),'$message','$subject', '1', '1')";

	$what = "INSERT INTO status (threadid,subject,fromid,toid,fromstatus,tostatus,dateposted) VALUES ('$threadid', '$subject', '$username', '$toid', '1', '1', now())";
	$doit = mysql_db_query($dbname,$what);
	$execute = mysql_db_query($dbname, $query);

Thank you

Best Regards,
Dhaval Desai


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-04 04:15 UTC]
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit
 [2002-04-05 15:06 UTC] dhaval_admas at yahoo dot com

Well I was running php 4.0.1pl2, and I recently upgraded to php 4.1. I think now it's solved.

But with that older version of php the problem is still there...
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 22:01:29 2024 UTC