php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #16397 domxml_unlink_node()
Submitted: 2002-04-02 12:59 UTC Modified: 2002-12-01 16:33 UTC
From: 2erudit at mail dot ru Assigned:
Status: No Feedback Package: Documentation problem
PHP Version: 4.1.2 OS: w2k
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-04-02 12:59 UTC] 2erudit at mail dot ru
$node - is DOM Element object

domxml_unlink_node($node) 
reports error: expects exactly 0 parameters, 1 given

but
$node->domxml_unlink_node()  
reports error as well: Call to undefined function:  domxml_unlink_node()

8-OOO
8-\\\

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-05 13:24 UTC] jtate@php.net
domxml_unlink_node should not be used:

Usage for 4.2.0:
domxml_node_unlink_node($nodetodelete);
or
$nodetodelete->unlink();

For future versions:
domxml_node_unlink_node($nodetodelete);
or
$nodetodelete->unlink_node();


 [2002-11-01 13:50 UTC] thle at it dot usyd dot edu dot au
I'm using a PHP 4.1.2 version on SunOS. I have tried to delete a DOM Element object by using:

$nodetodelete->unlink();

Actually, it works but it return a "The page cannot be display" page. What should I do? Thanhs a lot,

Harry
 [2002-11-18 17:41 UTC] philip@php.net
Please try PHP 4.3.0 as this extension is still experimental and many major changes have happened to it recently.
 [2002-12-01 16:33 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 10:01:32 2019 UTC