php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16376 Transformation does not work inside PHP
Submitted: 2002-04-01 11:26 UTC Modified: 2002-06-17 14:27 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: john at lerach dot cz Assigned:
Status: Not a bug Package: Sablotron XSL
PHP Version: 4.1.2 OS: Windows 2000
Private report: No CVE-ID: None
 [2002-04-01 11:26 UTC] john at lerach dot cz
Hello,

I've used this sample code as well as the installation described at http://shanx.com/php/xsl/getXsl.htm.

<?php
  // Create an XSLT processor
  $xsltHandle = xslt_create();

  // Perform the transformation
  $out = xslt_process($xsltHandle, getcwd().'test.xml', getcwd().'test.xsl');

  // Detect errors
  if(!$out) die(xslt_error($xsltHandle));

  // Destroy the XSLT processor
  xslt_free($xsltHandle);
?>

The result is that Sablotron itself works fine but this code produces following error "XML parser error 4: not well-formed (invalid token)".

Thank you.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-16 20:56 UTC] s dot li at gmx dot de
This is not a bug description, it's an April's fool joke :) Have you checked whether your xml file is well-formed?
 [2002-04-17 09:39 UTC] john at lerach dot cz
Unfortunately it's not joke but some php vs. sablotron version confusion.

As I wrote, "Sablotron itself works fine", which means (sorry if it's not explicit enough), that commandline program transforms given files well (it means xml files ARE well formed).

Xslt_process used via string parameters (not fileneme as abduced in example) works fine, so I don't handle this problem any more.

Thanx.
 [2002-06-02 17:48 UTC] k.schroeder@php.net
Please post your xsl and xml file to reproduce your problem.

Regards, Kai
 [2002-06-17 14:27 UTC] sterling@php.net
Coding error, not XSLT error, could be related to a variety of things...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 08:01:27 2019 UTC