php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16283 php fails to compile for apache 2.0.32
Submitted: 2002-03-26 06:23 UTC Modified: 2002-03-31 21:00 UTC
Votes:4
Avg. Score:4.5 ± 0.5
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:2 (50.0%)
From: lazy at server dot gwsh dot gda dot pl Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.1.2 OS: Linux
Private report: No CVE-ID: None
 [2002-03-26 06:23 UTC] lazy at server dot gwsh dot gda dot pl
php 4.1.2 fails to compile for apache 2.0.32
in sapi/apache2filter/sapi_apache2.c
in php_input_filter function ap_get_brigade() has wrong set of arguments
i changed it to f->next,bb,mode,APR_BLOCK_READ,* readbytes
it compiles and runs but i doubt is it correct

php configured with ./configure --with-apxs2=/usr/local/apache2/bin/apxs

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-26 07:15 UTC] sniper@php.net
reclassified
 [2002-03-26 07:58 UTC] sander@php.net
AFAIK, 4.1.2 can't compile at all with Apache 2.
Can you try 4.2.0RC1 and see if it works?
 [2002-03-26 08:31 UTC] lazy at server dot gwsh dot gda dot pl
4.1.2 has apache2filter
i fixed it and it compilled and hello world worked

i tryed 4.2 it also fails
"
sapi_apache2.c: In function `php_register_hook':
sapi_apache2.c:473: `AP_FTYPE_RESOURCE' undeclared (first use in this function)
sapi_apache2.c:473: (Each undeclared identifier is reported only once
"
but the ap_get_brigade() function is fixed
but the php_input_filter() also changed
 [2002-03-26 08:47 UTC] lazy at server dot gwsh dot gda dot pl
maybe some one know how to use ap_get_brigade() in php ?
i used APR_BLOCK_READ and changed bytelen from pointer to value
there is sth in apaches change log about changing
from pointer to value so this looks to be correct
but what about APR_BLOCK_READ or APR_NONBLOCK_READ
example filters in apache 2 use APR_BLOCK_READ so mayby it is correct ?

there is no AP_FTYPE_RESOURCE in apaches sources
 [2002-03-31 20:06 UTC] didier dot link at wanadoo dot fr
I've changed the AP_FTYPE_RESOURCE for AP_FTYPE_CONTENT and apache2 freeze without debug messages in error.log (config changed fr enable debug messages but nothing ...).
Wait for apache or/and php next beta release ?!
 [2002-03-31 21:00 UTC] yohgaki@php.net
Apache2filter SAPI is _experimental_ and there is no stable 
Aapche2 neither.

PHP 4.1.2 comples with Apache 2.0.28. IIRC.
If you are using CVS version of PHP, user CVS version of Apache2.


 [2002-04-10 07:06 UTC] klansman at arrakis dot dhis dot org
I tried to compile php 4.1.2 with to apache 2.0.35 (non beta according to httpd.apache.org)

It fails because of the reasons described in this bug. Someone (lazy@server.gwsh.gda.pl) told here that had php code fixed... Can you send the diffs? So i can try to compile the beast??

Thank you!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC