php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16229 PHP Complie with APXS2
Submitted: 2002-03-23 04:59 UTC Modified: 2002-04-06 11:13 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bugs at optonline dot net Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.2.0RC1 OS: Mandrake 8.1
Private report: No CVE-ID: None
 [2002-03-23 04:59 UTC] bugs at optonline dot net
!!! NOTICE: This is for 4.2.0RC1 !!

./configure works fine.

During make:

var_unserializer.c: In function `php_var_unserialize':
var_unserializer.c:300: warning: comparison is always false due to limited range of data type

and the other error:

Making all in sapi
make[1]: Entering directory `/root/php-4.2.0RC1/sapi'
Making all in apache2filter
make[2]: Entering directory `/root/php-4.2.0RC1/sapi/apache2filter'
make[3]: Entering directory `/root/php-4.2.0RC1/sapi/apache2filter'
/bin/sh /root/php-4.2.0RC1/libtool --silent --mode=compile gcc  -I. -I/root/php-4.2.0RC1/sapi/apache2filter -I/root/php-4.2.0RC1/main -I/root/php-4.2.0RC1 -I/www/include -I/root/php-4.2.0RC1/Zend -I/root/php-4.2.0RC1/ext/xml/expat  -D_REENTRANT -I/root/php-4.2.0RC1/TSRM -g -O2 -pthread -DZTS -prefer-pic  -c sapi_apache2.c
sapi_apache2.c: In function `php_register_hook':
sapi_apache2.c:473: `AP_FTYPE_RESOURCE' undeclared (first use in this function)
sapi_apache2.c:473: (Each undeclared identifier is reported only once
sapi_apache2.c:473: for each function it appears in.)
make[3]: *** [sapi_apache2.lo] Error 1
make[3]: Leaving directory `/root/php-4.2.0RC1/sapi/apache2filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/php-4.2.0RC1/sapi/apache2filter'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/php-4.2.0RC1/sapi'
make: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-23 04:59 UTC] bugs at optonline dot net
Changed the Version Number
 [2002-03-23 06:54 UTC] sander@php.net
What are your configure lines? (both of Apache and PHP)
Which version of Apache are you using? Can you try upgrading Apache  to 2.0.32 or the latest CVS?
 [2002-03-23 13:59 UTC] bugs at optonline dot net
No prob.

Version: Apache 2.0.32 - this is not the latest CVS
Downloaded file: http://www.apache.org/dist/httpd/httpd-2.0.32-beta.tar.gz
Configure lines: ./configure --quiet --prefix=/www
Errors: None. Works just fine.

I tired the lasest CVS (snapshot) about 2 days ago. I will try again, but I doubt it's the problem.

PHP Configure Lines: ./configure --quiet --with-mysql=no --with-apxs2=/www/bin/apxs

"make" fails -- see above for errors.
"make install" -- never created because of errors above
 [2002-03-25 15:49 UTC] sniper@php.net
reclassified
 [2002-03-29 16:15 UTC] eric at abovegod dot net
Same error for me.  Both with 4.1.2 and 4.2.0RC1.
I'm on slackware.

Making all in apache2filter
make[2]: Entering directory `/root/php-4.2.0RC1/sapi/apache2filter'
make[3]: Entering directory `/root/php-4.2.0RC1/sapi/apache2filter'
/bin/sh /root/php-4.2.0RC1/libtool --silent --mode=compile gcc  -I. -I/root/php-4.2.0RC1/sapi/apache2filter -I/root/php-4.2.0RC1/main -I/root/php-4.2.0RC1 -I/usr/local/apache2/include -I/root/php-4.2.0RC1/Zend -I/usr/local/include -I/root/php-4.2.0RC1/ext/mysql/libmysql -I/root/php-4.2.0RC1/ext/xml/expat  -D_REENTRANT -I/root/php-4.2.0RC1/TSRM -DTHREAD=1 -g -O2 -pthread -DZTS -prefer-pic  -c sapi_apache2.c
sapi_apache2.c: In function `php_register_hook':
sapi_apache2.c:473: `AP_FTYPE_RESOURCE' undeclared (first use in this function)
sapi_apache2.c:473: (Each undeclared identifier is reported only once
sapi_apache2.c:473: for each function it appears in.)
make[3]: *** [sapi_apache2.lo] Error 1
make[3]: Leaving directory `/root/php-4.2.0RC1/sapi/apache2filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/php-4.2.0RC1/sapi/apache2filter'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/php-4.2.0RC1/sapi'
make: *** [all-recursive] Error 1
 [2002-04-06 11:13 UTC] sniper@php.net
Get latest CVS of both Apache2 and PHP and it should work.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 08:01:25 2021 UTC