php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16203 Cannot configure with ming
Submitted: 2002-03-21 10:39 UTC Modified: 2002-04-24 08:33 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: chassaing at domisys dot com Assigned:
Status: Closed Package: Ming related
PHP Version: 4.2.0RC4 OS: FreeBSD 4.3-STABLE
Private report: No CVE-ID: None
 [2002-03-21 10:39 UTC] chassaing at domisys dot com
With PHP 4.2.0RC1, it is not possible to compile with the ming module anymore. The configure script fails saying : 

checking for MING support... yes
checking for Ming_useSWFVersion in -lming... no
configure: error: Ming library 0.2a or greater required.

Eventhough the ming library used REALLY is 0.2a and there's no problem using it with PHP 4.1.2 with the exact same configure options.

Detail of configure options :
./configure \
--prefix=/usr/home/xxxx/local \
--enable-bcmath \
--with-zlib \
--with-png-dir=/usr/local \
--with-jpeg-dir=/usr/local \
--with-tiff-dir=/usr/home/xxxx/local \
--with-t1lib=/usr/home/xxxx/local \
--with-freetype-dir=/usr/home/xxxx/local \
--enable-gd-native-ttf \
--with-gd=/usr/home/xxxx/local \
--enable-exif \
--with-mysql=/usr/local \
--with-ming=/usr/home/xxxx/local \
--disable-pear \
--with-config-file-path=/usr/home/xxxx/local/etc \
--enable-debug=no \
--enable-force-cgi-redirect=yes \
--with-openssl=/usr/local/ssl \
--with-curl=/usr/home/xxxx/src/curl-7.9 \
--with-dom=/usr/home/xxxx/local

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-21 10:39 UTC] chassaing at domisys dot com
(edited to put the right PHP version)
 [2002-03-21 11:01 UTC] sniper@php.net
What does config.log has to say about this?

 [2002-03-21 11:44 UTC] chassaing at domisys dot com
Part that seems to cover the problem (please specify if something else is needed - that file is looong) :

configure:37608: checking for mhash support
configure:37648: result: no
configure:37988: checking for MING support
configure:38028: result: yes
configure:38049: checking for Ming_useSWFVersion in -lming
configure:38076: gcc -o conftest -g -O2
    -L/usr/home/xxxx/local/lib -lm -ldl
    -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib -R/usr/home/xxxx/src/curl-7.9/lib -L/usr/home/xxxx/src/curl-7.9/lib -R/usr/home/xxxx/local/lib -L/usr/home/xxxx/local/lib -R/lib -L/lib conftest.c -lming  -lgd -lt1 -lfreetype -lpng -lz -ljpeg -lz -lm -lz -lxml2 -lcurl -lcrypto -lssl -lcurl -lz -lcrypt -lssl -lcrypto -lm  -lcrypt >&5
/usr/libexec/elf/ld: cannot find -ldl
configure:38079: $? = 1
configure: failed program was:
#line 38057 "configure"
#include "confdefs.h"

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */
char Ming_useSWFVersion ();
int
main ()
{
Ming_useSWFVersion ();
  ;
  return 0;
}
configure:38096: result: no
configure:38110: error: Ming library 0.2a or greater required.
 [2002-03-21 18:23 UTC] mfischer@php.net
Can you test if it works with current CVS ?
 [2002-03-22 04:16 UTC] chassaing at domisys dot com
The problem is exactly the same with the latest snapshot (dated march 22th 2002).
 [2002-03-22 05:37 UTC] wez@php.net
The problem is looks like it is actually with libdl
(for dlopen); could you send the part of the config.log
that mentions it?
 [2002-03-22 05:58 UTC] chassaing at domisys dot com
Here goes the part about opendl :

configure:7515: checking for dlopen in -ldl
configure:7542: gcc -o conftest -g -O2   conftest.c -ldl   >&5
/usr/libexec/elf/ld: cannot find -ldl
configure:7545: $? = 1
configure: failed program was:
#line 7523 "configure"
#include "confdefs.h"

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */
char dlopen ();
int
main ()
{
dlopen ();
  ;
  return 0;
}
configure:7562: result: no

Also way below :
ac_cv_header_arpa_inet_h='yes'
ac_cv_lib_dl_dlopen='no'
php_cv_cc_dashr='yes'
 [2002-03-26 20:48 UTC] amiroot at yahoo dot com
I'm using FreeBSD-4.5. Problem still exists in current CVS php4-200203261500.
 [2002-03-27 10:32 UTC] sniper@php.net
This should be fixed in CVS. (HEAD)
Can you please verify it and let me know and I'll merge
the fix to PHP 4.2.0 branch too.

--Jani

 [2002-03-27 22:01 UTC] small_root at yahoo dot com
tested with php4-200203271800 and erro exists again.

configure:37658: checking for Ming_useSWFVersion in -lming
configure:37685: gcc -o conftest -g -O2  -DMOD_SSL=208106 -DEAPI -DEAPI_MM -DUSE_EXPAT
    -L/usr/lib
    -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib -R/usr/X11R6/lib -L/usr/X11R6/lib conftest.$
/usr/local/lib/libc-client4.so: undefined reference to `mm_expunged'
/usr/local/lib/libc-client4.so: undefined reference to `mm_diskerror'
/usr/local/lib/libc-client4.so: undefined reference to `mm_lsub'
/usr/local/lib/libc-client4.so: undefined reference to `mm_flags'
/usr/local/lib/libc-client4.so: undefined reference to `mm_fatal'
/usr/local/lib/libc-client4.so: undefined reference to `mm_nocritical'
/usr/local/lib/libc-client4.so: undefined reference to `mm_notify'
/usr/local/lib/libc-client4.so: undefined reference to `mm_searched'
/usr/local/lib/libc-client4.so: undefined reference to `mm_status'
/usr/local/lib/libc-client4.so: undefined reference to `mm_login'
/usr/local/lib/libc-client4.so: undefined reference to `mm_list'
/usr/local/lib/libc-client4.so: undefined reference to `mm_critical'
/usr/local/lib/libc-client4.so: undefined reference to `mm_exists'
/usr/local/lib/libc-client4.so: undefined reference to `mm_log'

/usr/local/lib/libc-client4.so: undefined reference to `mm_dlog'
configure:37688: $? = 1
configure: failed program was:
#line 37666 "configure"
#include "confdefs.h"

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */ 
char Ming_useSWFVersion ();
int
main ()
{
Ming_useSWFVersion ();
  ;
  return 0;
}
configure:37705: result: no
configure:37719: error: Ming library 0.2a or greater required.
 [2002-04-19 11:14 UTC] chassaing at domisys dot com
Just tested with 4.2.0 RC4 and the bug is still there.
 [2002-04-19 11:32 UTC] sniper@php.net
What does config.log has to say about this?
 [2002-04-20 12:30 UTC] chassaing at domisys dot com
Here's what config.log says :

configure:37687: checking for Ming_useSWFVersion in -lming
configure:37714: gcc -o conftest -g -O2  
    -L/usr/home/xxxx/local/lib
    -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib -R/usr/home/xxxx/src/curl-7.9/lib -L/usr/home/xxxx/src/curl-7.9/lib -R/usr/home/xxxx/local/lib -L/usr/home/xxxx/local/lib -R/lib -L/lib conftest.c -lming  -lgd -lpng -lz -ljpeg -lz -lm -lz -lxml2 -lcurl -lcrypto -lssl -lcurl -lz -lcrypt -lssl -lcrypto -lm  -lcrypt >&5
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Init_FreeType'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Load_Glyph'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Done_Face'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Get_Kerning'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Get_Char_Index'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Get_Glyph'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Glyph_To_Bitmap'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Set_Char_Size'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Done_Glyph'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Glyph_Get_CBox'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_New_Face'
/usr/home/xxxx/local/lib/libgd.so: undefined reference to `FT_Glyph_Transform'
configure:37717: $? = 1
configure: failed program was:
#line 37695 "configure"
#include "confdefs.h"

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */
char Ming_useSWFVersion ();
int
main ()
{
Ming_useSWFVersion ();
  ;
  return 0;
}
configure:37734: result: no
configure:37748: error: Ming library 0.2a or greater required.
 [2002-04-20 13:18 UTC] sniper@php.net
Was the configure line same as before? (ie. same as in your
first note)

It looks like for some reason, the -lfreetype is not added
to the LIBS. Could you send me the whole config.log, please?

 [2002-04-23 11:57 UTC] chassaing at domisys dot com
Indeed I changed the config options (because GD 2.0.1 doesn't compile anymore either) and freetype had been removed. I made more test :
- it compiles fine without GD and freetype (so freetype is not required for ming ?)
- it breaks if I add GD (1.8 series) without freetype or another graphic extensions
 [2002-04-23 20:36 UTC] sniper@php.net
Is your GD library compiled with freetype support?
Please try PHP 4.2.0 and send me the full config.log
to sniper@php.net and I'll check what fails there.

The configure should fail while checking the GD library..

--Jani

 [2002-04-24 08:33 UTC] chassaing at domisys dot com
Apparently it's indeed related to other configure options : putting back freetype and libjpeg seems to make the it work (beside the GD compile problem, but it's another story). Closed the bug.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 20 10:01:37 2019 UTC