php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16151 French special characters
Submitted: 2002-03-18 13:32 UTC Modified: 2002-03-19 04:21 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: cris at tellme dot net Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.1.2 OS: windows 200
Private report: No CVE-ID: None
 [2002-03-18 13:32 UTC] cris at tellme dot net
Hello i want to insert in a MSSQL server 2000 some informations that are typed in french with ???? etc.. 
like this :
<?
	setlocale("LC_ALL","french"); 
	$li=mssql_connect("cris", "sa","");
	$db=mssql_select_db('v2tellme',$li);
	$test='????';
	$query="insert into toto values ('".$test."')";
	$rez = mssql_query("SET LANGUAGE french");
	echo $query;
	$rez = mssql_query($query);
	$query="SELECT test from toto";
	$qresp=mssql_query($query);
	$toto = mssql_fetch_array ($qresp);
	echo $toto[0]; 
	mssql_close($li);
?>

and after that in the database is just this TFta 

WHY????????????

i am not  understanding!!!!!!!!!!!!!!!!!!!?????

PLEASE HELP ME  !!!!!!!!!!!!!!

thank you fou your help ,

Cris Badea
Web Developer
Tellme SA

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-19 04:21 UTC] sander@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php


 [2002-04-21 06:26 UTC] bs_php at infeer dot com
setlocale() on windows is the problem!
See bug #16718 
http://bugs.php.net/bug.php?id=16718
 [2002-05-16 06:16 UTC] oldiesf at multimania dot com
Hello !

i have similar problem :

environment:
Windows 2000 Pro
SQL Server 2000
PHP 4.1.1

- i insert the caracter "?" in a table using mssql functions.

- when i read the table in Entreprise Manager :
i have "?" instead of "?"

- i replace "?" by "?" in Entreprise Manager

- when i read the table with php mssql functions :
i have "," instead of "?"

sorry for my poor english
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 02:05:55 2022 UTC