php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16140 In ISAPI modules can't create a large string more than 444K
Submitted: 2002-03-18 06:28 UTC Modified: 2002-03-18 22:08 UTC
From: shockeye at etang dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 4.1.2 OS: windows 2000
Private report: No CVE-ID: None
 [2002-03-18 06:28 UTC] shockeye at etang dot com
W2K professional+IIS 5+PHP4.1.2(ISAPI)
Example,there is a data file named test.hdb about 1.1M,I want read it to a string.

		function readFiles ($path) {
			$fopen = fopen ($path,'r');
			$fread = fread ($fopen,$this->file_size);
			fclose ($fopen);

			return $fread;
		}
$fread = readFiles('test.hdb');
$fp = fopen('test2.hdb');
fwrite($fp, $fread);
fclose($fp);

Result test2.hdb only about 444K,I think something lost.

It runs good in CGI modules,but fail in ISAPI.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-18 09:14 UTC] sniper@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php
 [2002-03-18 22:08 UTC] shockeye at etang dot com
Not a help!This is a bug in ISAPI I think.Because I can not create a string > 455453 byte.But this codes run at CGI module good.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 14:01:27 2019 UTC