php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16099 Include_path predefined
Submitted: 2002-03-15 13:53 UTC Modified: 2002-04-16 00:00 UTC
Votes:4
Avg. Score:4.8 ± 0.4
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:2 (50.0%)
From: admin at malayx dot com Assigned:
Status: No Feedback Package: Output Control
PHP Version: 4.1.2 OS: WindowsXP
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-03-15 13:53 UTC] admin at malayx dot com
Warning: Failed opening 'configuration.php' for inclusion (include_path='c:\php4\pear') in g:\home\malay\public_html\classes\test.php on line 2

php installed directory
------------------------
G:\PHP

Apache installed directory
-------------------------
G:\Apache

Server Document root
----------------------
G:\home\malay\public_html

Directory Structure
-------------------
home-
     |_
        malay
         |_
           public_html________
                |             |
           configuration.php  | 
           test1.php          |
                              |_
                                classes
                                    |
                                  test.php

script for test1.php
--------------------
<?
include ("classes/test.php");
echo "Welcome to my testing site";
?>

Script for test.php in classes folder
-------------------------------------
<?
include ("configuration.php");
?>
-------------------------------------

This is just a test script to see if the include("classes/test.php") in test1.php make test.php at the same directory level with the test1.php as previous version of PHP did. 

Note: Even my working postnuke local dev site did function anymore due the same problem. Another thing I did not set anything on "include_path" directive. Even I did it make no different. Tried that.

Hope someone can help and thanks in advance.

 
                               
  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-15 16:52 UTC] sniper@php.net
This should be fixed in CVS. And setting include_path
in php.ini to this:

include_path = ".;c:\php4\pear" 

should fix it too. (ie. no need to wait for release)


 [2002-03-18 20:50 UTC] HummerX123 at hotmail dot com
I got almost the same problem on windows 2k after I upgrade to 4.1.2 :(
all the php script stop working and output the warning

Warning: Failed opening 'path of the script' for inclusion (include_path='.;c:\php4\pear') in Unknown on line 0

I tried the include_path = ".;c:\php4\pear" that didn't fix the problem.
 [2002-03-28 16:52 UTC] zenderx@php.net
I've noticed that adding the drive letter to a relative path has to be done to get all working (apart from setting the include_path as it is said was said by sniper@php.net.

But it breaks the interportability of the path names (as it was for e.g. "/web/include/php_class.php" now it
has to be "c:/web/include/php_class.php".
 [2002-04-16 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-05-03 15:28 UTC] andyd at research dot panasonic dot com
I have this same problem too. Changing the 
include_path = ".;c:\php4\pear" does not fix the problem. What did work was
include_path = ".;c:\;c:\php4\pear"

I think that the problem is that absolute paths are no longer recognized and that every path is used as if it were relative.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 16:03:36 2021 UTC