php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16062 unable to ./configure with ldap enable
Submitted: 2002-03-14 07:54 UTC Modified: 2002-03-17 20:17 UTC
From: jeffrey at time dot net dot my Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.1.2 OS: aix4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeffrey at time dot net dot my
New email:
PHP Version: OS:

 

 [2002-03-14 07:54 UTC] jeffrey at time dot net dot my
configure line
--------------
./configure --without-mysql --with-apxs=/usr/local/apache/bin/apxs \
--with-ldap=/webserver/download/ldapsdk

After run configure
-------------------
Something is likely to be messed up here, because the configure script was not able to detect a simple feature on your platform. This is often caused by incorrect configuration parameters. Please see the file debug.log for error messages.

message from debug.log
-----------------------
CONFIGURE:   './configure' '--without-mysql' '--enable-sigchild' '--with-apxs=/usr/local/apache/bin/apxs' '--with-oci8=/home/o
racle' '--with-ldap=/home/oracle'
CC:         gcc
CFLAGS:     -g -O2
CPPFLAGS:    -DAIX=43 -DUSE_PTHREAD_SERIALIZED_ACCEPT -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -DUSE_EXPAT
CXX:        
CXXFLAGS:   
INCLUDES:    -I/usr/local/apache/include  -I$(top_builddir)/Zend -I/home/oracle/include
LDFLAGS:     -L/home/oracle/lib -L/home/oracle/lib
LIBS:       -lld -lbsd_r -lodm -lm -ldl -lldapssl41 -lplds3 -lplc3 -lnspr3 -lcrypt -lbind -lm -ldl  -lcrypt -lclntsh
DLIBS:      
SAPI:       apache
PHP_RPATHS:  /home/oracle/lib
uname -a:   AIX cupang 3 4 000B7B9D4C00

gcc -o conftest -g -O2  -DAIX=43 -DUSE_PTHREAD_SERIALIZED_ACCEPT -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -DUSE_EXPAT  -L/home/oracl
e/lib -L/home/oracle/lib conftest.c -lld -lbsd_r -lodm -lm -ldl -lldapssl41 -lplds3 -lplc3 -lnspr3 -lcrypt -lbind -lm -ldl  -l
crypt -lclntsh >&5
ld: 0706-006 Cannot find or open library file: -l ldapssl41
        ld:open(): No such file or directory
ld: 0706-006 Cannot find or open library file: -l plds3
        ld:open(): No such file or directory
ld: 0706-006 Cannot find or open library file: -l plc3
        ld:open(): No such file or directory
ld: 0706-006 Cannot find or open library file: -l nspr3
        ld:open(): No such file or directory
collect2: ld returned 255 exit status


I have tried php4latest.tar.gz. version 4.1.2 and still cannot

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-14 08:10 UTC] sander@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php

Please do NOT report the same problem twice!
 [2002-03-17 20:17 UTC] jeffrey at time dot net dot my
Hi Sander,
Sorry I pasted the wrong debug.log. below is the correct one. The reason I say this is a bug because this kind of error was reported on oracle and was solved by fixing the configure script. Here is the link. http://bugs.php.net/?id=10811&edit=2 

Hope you can help me. Thanks


CONFIGURE:   './configure' '--without-mysql' '--with-apxs=/usr/local/apache/bin/apxs' '--with-ldap=/webserver/download/ldapsdk
'
CC:         gcc
CFLAGS:     -g -O2
CPPFLAGS:    -DAIX=43 -DUSE_PTHREAD_SERIALIZED_ACCEPT -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -DUSE_EXPAT
CXX:        
CXXFLAGS:   
INCLUDES:    -I/usr/local/apache/include  -I$(top_builddir)/Zend -I/webserver/download/ldapsdk/include
LDFLAGS:     -L/webserver/download/ldapsdk/lib -L/webserver/download/ldapsdk/lib
LIBS:       -lldapssl41 -lplds3 -lplc3 -lnspr3 -lcrypt -lbind -lm -ldl  -lcrypt
DLIBS:      
SAPI:       apache
PHP_RPATHS:  /webserver/download/ldapsdk/lib
uname -a:   AIX cupang 3 4 000B7B9D4C00

gcc -o conftest -g -O2  -DAIX=43 -DUSE_PTHREAD_SERIALIZED_ACCEPT -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -DUSE_EXPAT  -L/webserver/
download/ldapsdk/lib -L/webserver/download/ldapsdk/lib conftest.c -lldapssl41 -lplds3 -lplc3 -lnspr3 -lcrypt -lbind -lm -ldl  
-lcrypt >&5
ld: 0706-006 Cannot find or open library file: -l ldapssl41
        ld:open(): No such file or directory
ld: 0706-006 Cannot find or open library file: -l plds3
        ld:open(): No such file or directory
ld: 0706-006 Cannot find or open library file: -l plc3
        ld:open(): No such file or directory
ld: 0706-006 Cannot find or open library file: -l nspr3
        ld:open(): No such file or directory
collect2: ld returned 255 exit status
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 13:01:23 2020 UTC