php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #16001 File-Upload's mime-type in Opera
Submitted: 2002-03-11 13:40 UTC Modified: 2002-03-11 13:42 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: spot at ihastus dot net Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 4.1.2 OS: Linux
Private report: No CVE-ID: None
 [2002-03-11 13:40 UTC] spot at ihastus dot net
There seems to be a problem when getting uploaded file's mime-type. The problem occurs only with Opera.

The file is uploaded correctly, and then I try to check the uploaded file's mime-type.

$userfile_type gives:
image/gif; name=\"logo3.gif\"

It should be of cource only "image/gif". And the name should be reported only in $userfile_name, not in $userfile_type.

So I'll have to write a correction to every my scripts involved with file-uploads.

Correction I have made:
list ($userfile_type) = split(";", $userfile_type);

I have made an example page for uploading images, which is in the address:
http://ihastus.net/phpbug/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-11 13:42 UTC] sniper@php.net
This bug has been fixed in CVS.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 21:01:27 2024 UTC