php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15982 PHP Freeze with swffont() call
Submitted: 2002-03-10 07:56 UTC Modified: 2002-10-25 01:00 UTC
Votes:59
Avg. Score:4.8 ± 0.5
Reproduced:55 of 55 (100.0%)
Same Version:41 (74.5%)
Same OS:39 (70.9%)
From: tonalgeek at hotmail dot com Assigned:
Status: No Feedback Package: Ming related
PHP Version: 4.x.x OS: Win XP Prof
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-03-10 07:56 UTC] tonalgeek at hotmail dot com
When SWFFont() is called with a fdb file (not with internal fonts like '_sans') PHP appears to do nothing until the time limit for scripts is reached.
Here is a reproductible example:

<?php

x=new SWFMovie();
y=new SWFFont("_sans"); // <---- does not freeze here
z=new SWFFont("foo.fdb");
// <--- PHP does not execute at and below this point

?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-04 03:50 UTC] oevloev at scadasoft dot ru
I had the same bug on Win2000+php.4.1.2. When called SWFFont function with same normal (worked on previous version ) *.fdb file, php module crashes and sometime crash the web server (Apache). 
It is very important to have the text in generated Flash movies, but it does not work in Ming 0.2 version.
 [2002-06-04 04:29 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-07-12 12:13 UTC] yann dot lossouarn at tak dot net
I'm currently using the "EasyPHP 1.6" distrib, which includes Apache 1.3.20 and PHP 4.2.0, used on a NT4 station, and encountered the same problem. Any solution known ?

Cheers,
Yann
 [2002-07-12 20:58 UTC] tonalgeek at hotmail dot com
This bug also exists in 4.2.1
 [2002-08-01 13:20 UTC] mabuzzer at hotmail dot com
I've managed to eliminate the web server from the equation - ran the test script from the command line, and got the same result. The script hung until it reached the timeout limit, and consumed 97% of the CPU time while it was hung. 

It also seemed to keep consuming more and more memory, as if it was stuck in some kind of infinite loop?

This was using PHP 4.2.2, Ming 0.2a which I downloaded from php.net. This is quite important for me, cos I have a couple of applications which I haven't been able to upgrade beyond PHP 4.0.4 (with Ming 0.9a) for one reason or another, and there are security issues involved in that.

Thanks
Richy Black
 [2002-08-21 16:42 UTC] rkenny at waukbearing dot com
I've experienced this bug as well.  I'm running Windows 2000 Server, IIS, and PHP 4.1.2.  The system has all of the "critical" Microsoft patches applied except for W2K SP3.

It seems that if I do a SWFFont("somefile.fdb") IIS will report a CGI error after running for perhaps 5 seconds.  

There are some Dr. Watson entries in my event log which talk about an access violation.  The dates and times of these entries roughly correspond to when I was testing the ming font functions, but when I run the scripts now, I just get the CGI errors without the Dr. Watson entries.

I thought I could get around this bug by using SWFFont("_sans"), but that does not work either.  I can create a new font object just fine, but when I try to add() the font object to the movie object, Internet Explorer dies, and asks if I want to send a bug report ot Microsoft.
 [2002-08-22 12:10 UTC] rkenny at waukbearing dot com
I tried installing PHP 4.1.1 and 4.1.0, but had the same problem under those versions.  I also switched from the CGI version of PHP to the ISAPI DLL -- but that didn't help either.  When I was running the PHP ISAPI DLL, I could see an "access violation" error directly in my web browser, whereas before it just said "CGI error".
 [2002-08-29 01:55 UTC] drdee at bigfoot dot com
My system: Win-98, Apache 1.3.26, PHP 4.2.1 -- trying to set SWFFont(), e.g.  

   $f=new SWFFont("ParkAvenue_BT.fdb"); 

usually crashes Apache, sometimes the browser (IE 5.5) too. However the system fonts ("_sans", "_serif", "_typewriter") are now working although they weren't at first. Weirdness!
 [2002-08-29 02:37 UTC] derick@php.net
Can you send me that font file by (private) e-mail?

Derick
 [2002-08-30 07:59 UTC] henri_simpson at yahoo dot com
Hi all, same problem for me:
Iexplorer systematically crashes using a file:
  SWFFont("verdana.fdb");
Iexplorer crashes sometimes using an internal font:
  SWFFont("-sans");
Could you please help.
 [2002-09-23 08:02 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-09-25 04:01 UTC] henri_simpson at yahoo dot com
Hello,

I think this is not fair, the bug is 100 % reproduced at every tentative, you cannot say "you are no longer experiencing the problem".
What should I do to make this bug is taken in account ?

Henri
 [2002-09-25 04:14 UTC] tonalgeek at hotmail dot com
The problem is definitely not gone. Opened this bug...
 [2002-09-25 05:37 UTC] derick@php.net
I didnt recieve any font file, setting to feedback
 [2002-09-28 04:03 UTC] php at mled dot net
you'll find some .fdb fonts at: http://www.neuralust.com/~mingdocs/fonts/getfonts.htm
 [2002-10-09 16:18 UTC] jmartin at jplstudios dot com
Still an issue.  Running Apache 2.0.40 with php 4.2.3 and ming 2a all on Windows 2000 Pro.  

ERROR message as follows:
The instruction at "0x00bacf0c" referenced memory at "0x00ad8000". The memory could not be "written".
 [2002-10-09 20:01 UTC] tonalgeek at hotmail dot com
I know the bug still exists in Ming. Anyway if you want an alternative that works there is FreeMovie/PHP http://freemovie.sourceforge.net/.
 [2002-10-09 20:41 UTC] iliaa@php.net
Using the latest CVS I am unable to replicate this crash on Linux, so this is most likely a Windows only bug.
I do however see a number of memory leaks caused by this extension:
/home/rei/PHP_CVS/php4/Zend/zend_hash.c(178) :  Freeing 0x083A1AA4 (32 bytes), script=m.php
Last leak repeated 2 times
/home/rei/PHP_CVS/php4/Zend/zend_API.c(597) :  Freeing 0x083A1A44 (44 bytes), script=m.php
/home/rei/PHP_CVS/php4/Zend/zend_API.c(585) : Actual location (location was relayed)
Last leak repeated 2 times

Using Google I found the following archive of fdb fonts, http://todbot.com/ming/tsts/fonts/, the url provided by php@mled.net does not appear to work.
 [2002-10-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-12-03 15:53 UTC] weishengli at yahoo dot com
Hi,

This problem in Windows OS is actually caused by call function
SWFShape_setRightFill().

In turn it goes to the function 
newShapeRecord()

I changed the following line in this function

  return shape->records[shape->nRecords++];

as
  shape->nRecords++;
  return shape->records[shape->nRecords-1];

It solves the problem.

However, I didn't look at it deeply.

The one who is distributing the Windows DLL should think about it.


Weisheng
 [2003-09-23 05:58 UTC] nospam at shaper dot it
It is working with ming 0.3a available at CVS.
Look here: http://kromann.info/php4.php and download the dll. On my system (Win2000/IIS 5.0 with PHP 4.3.2) it works very fine.
 [2004-02-28 19:03 UTC] mikkelbo at stofanet dot dk
I'm having the same problem. My config:

WinXP
ming-0.3beta1
PHP 4.3.4
Apache 1.3.23
IE 6.0

I have the latest dll's from
http://kromann.info/php4.php

-- 
Mikkel Rasmussen
 [2004-07-08 15:07 UTC] php at strawp dot net
I've just gotten hold of Ming yesterday and I am using the dll from http://kromann.info/php4.php

I'm having to restart apache every time I try and get the tutorial script off ming.sourceforge.net to run because of this bug. Has anyone got a Windows dll that will work?

If so, please mail it to me (in an archive file of some kind - it will probably be blocked otherwise)

Cheers,
Strawp
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 21:01:25 2020 UTC