php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15943 Viewing .phps Crashes with php.ini-recommended
Submitted: 2002-03-07 21:00 UTC Modified: 2003-08-28 12:21 UTC
Votes:6
Avg. Score:4.0 ± 1.0
Reproduced:6 of 6 (100.0%)
Same Version:2 (33.3%)
Same OS:3 (50.0%)
From: hans at nyphp dot org Assigned: zeev (profile)
Status: Closed Package: Scripting Engine problem
PHP Version: 4.3.3 OS: any
Private report: No CVE-ID: None
 [2002-03-07 21:00 UTC] hans at nyphp dot org
I've installed 4.1.2 and everything works fine with the latest Apache release on the latest FreeBSD release.  However, when I try to view a .phps page, the connection to the browser closes abruptly.  I was using the supplied php.ini-recommended, and after playing around for a while, saw that using php.ini-dist cleared the problem up.  I've looked at both php.ini's supplied with the source, but can't see any difference that would effect this.

How can using php.ini-recommended (doesn't work) versus php.ini-dist (works) make a difference, and how can this be straightened out? 

Thank you,

Hans

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-09 12:46 UTC] michael dot mauch at gmx dot de
I can verify that this bug is not solved as of php4-200207081200 - I'm on Linux/Intel, Apache 1.3.26.

# HEAD http://127.0.0.1/~elmicha/php/phpinfo.phps
500 EOF instead of reponse status line
Client-Date: Tue, 09 Jul 2002 16:32:58 GMT

# GET http://127.0.0.1/~elmicha/php/phpinfo.phps >xxx
<HTML>
<HEAD><TITLE>An Error Occurred</TITLE></HEAD>
<BODY>
<H1>An Error Occurred</H1>
500 EOF instead of reponse status line
</BODY>
</HTML>

# cat xxx
# cat ~/php/phpinfo.php
<?
	phpinfo();
?>

With "output_buffering = off", it works without problems.
 [2002-10-03 22:46 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-04 00:16 UTC] yohgaki@php.net
This problem is not os/version specific.

Zeev hasn't committed patch yet. It will be reimplemented much like normal function. Then it should work for any configuration.

Do not use output buffer to work around this problem.

Assigned to Zeev.


 [2003-04-09 18:07 UTC] gk at proliberty dot com
It looks like this problem has been shelved for a long time now so I wanted to let you know that it still exists in:
4.3.2-RC
php4-STABLE-200303241830

Changing output_buffering=Off solves the problem.
However, php does NOT crash - it simply returns no content.
This problem does NOT occur using php SAPI CLI however, only with mod_php
 [2003-08-12 21:06 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Unable to replicate using latest CVS shapshot.
 [2003-08-17 18:33 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-08-28 12:16 UTC] hans at nyphp dot org
There seems to be an error in ./configure with php4-STABLE-latest.tar.gz tagged 200308281530.  So, I tried php-4.3.3-RELEASE and it's look to work fine out of the box and using php.ini-recommended.  So, I'd say this is closed.  Thanks Zeev.

Hans
 [2003-08-28 12:21 UTC] iliaa@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 02 00:01:23 2020 UTC