php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15873 special build error with apache using php module after system-compoment changed
Submitted: 2002-03-05 08:30 UTC Modified: 2002-05-30 00:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: Xuefer at 21cn dot com Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.1.2 OS: rh linux 7.2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-03-05 08:30 UTC] Xuefer at 21cn dot com
what i did:
step1:
redhat7.2
with gd/jpeg/... support
build php as apache module
ok, works

step2:
uninstall some of the redhat rpm
download gd/jpeg and build it
reconfig php; make clean; make; make install;
all passed;

step3:
now reconfig apache, rebuild apache
failed! undefined reference to gdImageCreate gdImage....
and so on...

i've tried so many times, still get such error.

and by change, i did the following command in apache src-package directory:
[apache]# rm src/modules/php4/libphp4.module
and:
[php]# make install
[apache]# make

all pass! it works.


in a word, libphp4.module was not reinstalled correctly!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-06 06:12 UTC] sander@php.net
This might be caused by multiple versions of GD being installed. Check if the old version is really gone and try again :)
 [2002-03-06 13:16 UTC] Xuefer at 21cn dot com
well, i did have uninstalled gd-1.4.8 (i didn't notice the version before), by "rpm -e gd-1.4.8"

but the version i reinstall is also gd-1.4.8 source
and compile/install to /usr/local/ (rpm version should be /usr/)

i've done "rm -f config.cache"
dunno why "configure" still think that nothing changed
so can't link with gd and give out "undefined reference" error
 [2002-04-22 18:40 UTC] roach at dopegoat dot com
I am experiencing the same problem. I have built freetype, libpng and gd myself, if theres a problem linking to the wrong gd (which there does not appear to be) it would be a php bug, as the path to gd was explicitly stated.

gcc  -DLINUX=22 -I/root/php-4.1.2 -I/root/php-4.1.2/main -I/root/php-4.1.2/main -I/root/php-4.1.2/Zend -I/root/php-4.1.2/Zend -I/root/php-4.1.2/TSRM -I/root/php-4.1.2/TSRM -I/root/php-4.1.2 -DNO_DL_NEEDED `./apaci`    \
      -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/php4/libphp4.a main/libmain.a ./os/unix/libos.a ap/libap.a    -Wl,-rpath,/usr/local/freetype-1.3.1//lib -Wl,-rpath,/usr/local/gd-1.8.4//lib -Wl,-rpath,/opt/sybase-11.9.2//lib  -rdynamic -L/usr/local/freetype-1.3.1//lib -L/usr/local/gd-1.8.4//lib -L/opt/sybase-11.9.2//lib -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodphp4  -lpam  -ldl -linsck -lsybtcl -lintl -lcomn -lct -lcs -lsnmp -lgd -lttf -lcrypt -lssl -lcrypto -lresolv -lm -ldl -lnsl  -lresolv -lcrypt -lssl -lcrypto   -lm -lcrypt -lexpat
modules/php4/libphp4.a(gd.o): In function `zif_imagecreatefromstring':
/root/php-4.1.2/ext/gd/gd.c:1043: undefined reference to `gdImageCreateFromJpegCtx'
modules/php4/libphp4.a(gd.o): In function `zif_imagecreatefromjpeg':
/root/php-4.1.2/ext/gd/gd.c:1216: undefined reference to `gdImageCreateFromJpegCtx'
/root/php-4.1.2/ext/gd/gd.c:1216: undefined reference to `gdImageCreateFromJpeg'
modules/php4/libphp4.a(gd.o): In function `zif_imagejpeg':
 [2002-04-22 23:43 UTC] Xuefer at 21cn dot com
if u r using php as apache-module
you should always re-run apache "configure" after php "make install"

.. php# make install
.. php# cd ..\apache
.. apache# ./configure --with yor options
.. apache# make
.. apache# make install

does this ok for u ?
 [2002-05-30 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jan 23 08:01:24 2019 UTC