php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15688 undefined symbol:stat
Submitted: 2002-02-23 09:36 UTC Modified: 2003-02-26 08:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: wleyer at compuserve dot com Assigned:
Status: Closed Package: Informix related
PHP Version: 4.1.1 OS: SuSe Linux 7.3
Private report: No CVE-ID: None
 [2002-02-23 09:36 UTC] wleyer at compuserve dot com
i can configure PHP4 with Informix as dynamic module without getting errors. But when i try to start th Apache server i get the error message
Cannot load /usr/lib/apache/libphp4.so into server: opt/informix/lib/esql/libifgen.so: undefined symbol
/usr/sbin/apachectl start: httpd could not be started

configure:
./configure --with-config-file-path=/etc --with-apxs --with-informix

Linux		version: Suse 7.3
Informix cdsk	version: 9.51UC1
Make:		version 3.79.1
gcc		version: 2.95.3
flex		version: 2.5.4
bison		version: 1.28
httpd		version: 1.3.20

I trying since several days to get it running, i have serched a lot of sites for a solutiion, and tried out several changes in generating and setting Variables but it's always the same.
Can the problem solved by PHP or is it a problem of the 
Informix cdsk?


Thanks for any help.

Winfried

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-02 08:17 UTC] roland dot wintgen at t-online dot de
The problem is CSDK 2.70. Try getting the older version 2.60. Unfortunately it is no more available on the website "www.informix.com/evaluate". There has somethings changed between the two versions which produces this error.
There was a discussion about this in comp.databases.informix about the end of the year 2001. Take a look at: http://dbforums.com/archive/40/2001/12/1/218803
 [2002-04-25 05:10 UTC] isaac dot hopley at no_spam dot morton-fraser dot com
I have constantly had similar problems.  The only comination of Platform I can successfully compile on is:
SuSe 7.2
PHP 4.06
Apache 1.3.19

Using the CSDK 2.70 UC1

Very annoying as I would like to be using the latest versions of all these.

Anyone have a copy of CSDK I could have to try ??
 [2002-05-25 09:14 UTC] derick@php.net
Dup of #13655
 [2002-06-13 04:25 UTC] michael at ettl dot at
the problem only occurs when configuring as dynamic module.
i built the php executable with
# ./configure --with-informix
and dumped my php-File containing some Informix-Selects on php
# ./php < test.php 
and it worked fine.

Linux		version: Suse 7.3
Informix cdsk	version: 9.51UC1
httpd           version: 1.3.24
php             version: 4.2.1

Then i tried to compile php as static into apache - but this didn't work with php 4.2.1 as i got the error
"libtool: link: only absolute run-paths are allowed" on linking.

So i took php 4.1.2 and compiled it into apache and it worked.
 [2002-06-15 20:35 UTC] sniper@php.net
This snapshot _should_ fix the problem:

http://snaps.php.net/php4-latest.tar.gz

It works fine for me with the 2.70.UC3 which is the latest I found from the informix site.

--Jani


 [2002-07-16 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-02-26 08:56 UTC] nobbie@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See Bug: #13655
 [2003-02-26 08:57 UTC] sniper@php.net
restore original email address..

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 01:01:31 2024 UTC