php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15623 build script fails to link "nss_dns" library
Submitted: 2002-02-19 10:25 UTC Modified: 2002-05-25 00:00 UTC
From: ognio at peruserver dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.1.1 OS: Linux (SuSE 6.4)
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-02-19 10:25 UTC] ognio at peruserver dot com
System:
SuSE Linux 6.4
Apache 1.3.23
PHP 4.1.1

WHAT HAPPENED:

I compile PHP as a DSO module against Apache 1.3.23 and everything looks ok but then when I try to load the
module the httpd binary won't run complaining of unresolved
symbols: "undefined reference to `__dn_skipname"

HOW I "FIXED" IT.

I found this message: 

http://www.geocrawler.com/archives/3/5/2000/5/0/3821638/

Referencing bug #4739. I did as suggested adding
EXTRA_LIBS="-lnss_dns" in Apache's Configuration file and
then it all worked as expected.

Is this an Apache or PHP bug?

Thanks. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-22 23:57 UTC] sniper@php.net
Does PHP 4.2.0 and Apache 1.3.24 work any better for you?

 [2002-05-25 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 22:01:26 2019 UTC