php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15578 PHP Causes Apache segmentation when using FreeTDS
Submitted: 2002-02-15 15:16 UTC Modified: 2002-03-26 10:30 UTC
Votes:6
Avg. Score:4.5 ± 0.8
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:4 (66.7%)
From: loginx at linkadmin dot org Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.1.2 OS: Linux Red Hat 7.2
Private report: No CVE-ID: None
 [2002-02-15 15:16 UTC] loginx at linkadmin dot org
Hi,

I need to access a MS-SQL server 2000 from a linux RH7.1 box running PHP 4.1.1 compiled with the following options:
./configure --with-sybase=/usr/local/freetds --with-apxs
And freetds installed from RPM (but I also tried with the source and it didn't work either... tried FreeTDS from CVS as well). and apache 1.3.19.
PHP seems to be working fine and phpinfo(); seems fine...
Whenever I load a PHP script that uses any mssql_* function, the page cannot load "The page cannot be displayed"...
When I check apache's error log, it reports Segmentation Fault on child process.
I tried with different versions of PHP and it always crashes the same way but the Perl applications using FreeTDS to connect to the same server work just fine so it probably is a problem related to PHP.

Any input ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-15 16:05 UTC] sander@php.net
To properly diagnose this bug, we need a backtrace to see what is
happening behind the scenes. To find out how to generate a backtrace,
please read http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open".
 [2002-02-25 14:44 UTC] loginx at linkadmin dot org
Well I tried the same thing with another configuration and it seemed to be working so I think it might be an apache related problem.

I will upgrade to the latest version of Apache in the next week or so so I will get a backtrace then if the problem persists.

Thank you.
 [2002-03-11 13:47 UTC] loginx at linkadmin dot org
Okay well now I upgraded to apache 1.3.20, and php 4.1.2 and freetds 0.53, I don't even get as far as the segmentation fault anymore because after compiling PHP with:
./configure --with-apxs --with-sybase=/usr/local/freetds --with-pspell
and make and make install, apache doesn't seem to be running anymore, I do /etc/rc.d/init.d/httpd restart and the following message appears:
Starting httpd: Syntax error on line 260 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: dbdead    [FAILED]

I could not find a way to solve this problem.
 [2002-03-26 10:30 UTC] loginx at linkadmin dot org
After formatting the server and reinstalling redhat latest version, I am not experiencing the problem anymore, it seems it was a redhat configuration issue more than a PHP related problem.

Thanks.

Xavier.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 14:01:31 2024 UTC