php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15514 HTML incorrect URL's generated by session code.
Submitted: 2002-02-11 21:10 UTC Modified: 2002-02-12 00:08 UTC
From: chrisc at shad0w dot org dot uk Assigned:
Status: Closed Package: URL related
PHP Version: 4.1.1 OS: Linux
Private report: No CVE-ID: None
 [2002-02-11 21:10 UTC] chrisc at shad0w dot org dot uk
When PHP generates a URL with a session ID in it and there's already a variable being passed in the URL, causing it to use an &, it creates a URL which just says & and not & which isn't HTML correct.

It's more a niggle than a bug, it's stopping my pages validating correctly ;)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-11 21:32 UTC] elixer@php.net
Duplicate of #15504
 [2002-02-12 00:08 UTC] mfischer@php.net
See 'arg_separator.output' in PHP.INI
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 07:03:34 2021 UTC