php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15439 PHP hangs web server when started
Submitted: 2002-02-07 17:25 UTC Modified: 2002-11-05 01:00 UTC
Votes:7
Avg. Score:4.7 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:1 (14.3%)
Same OS:5 (71.4%)
From: cboyce45 at yahoo dot com Assigned:
Status: No Feedback Package: iPlanet related
PHP Version: 4.0.6 OS: AIX 4.3.3
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-02-07 17:25 UTC] cboyce45 at yahoo dot com
The web server hangs when you go to a page, almost seems like a loop and does not seem to time out.  When php is commented out in obj.conf, magnus.com, and mime.types the webserver works fine.

I am using iPlanet 4.1 SP9, on AIX 4.3.3

I have downloaded and installed gcc, bison, flex, autoconf, automake, make and many others from freeware.bull.net

export PATH=/usr/local/bin:$PATH:/usr/vac/bin:/usr/ccs/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

PHP 4.0.6 compile line
CC=gcc ./configure --without-mysql \
 --with-nsapi=/usr/netscape/server4 \
 --with-dbm \
 --with-gdbm \
 --enable-libgcc

compiles fine, i used dump -n to see the libpthread was included.  I have even tried to compile this without dbm and gdbm support and still the same problem.

Thanks for any help,

Chris 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-07 21:56 UTC] yohgaki@php.net
The version of PHP that this bug was reported in is too old. Please
try to reproduce this bug in the latest version of PHP (available
from http://www.php.net/downloads.php

If you are still able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
 [2002-02-08 21:28 UTC] cboyce45 at yahoo dot com
I tried to compile php 4.1.1 before I used 4.0.6, but 4.1.1 would run through the ./configure, and make, and fail on make install.  It would not make libphp4.so where 4.0.6 had no problem making libphp4.so.

Thanks,

Chris
 [2002-02-28 09:13 UTC] lbalbalba at hotmail dot com
I have the same problem, on the same platform using the same PHP version, and reproducible for PHP 4.1.1 and 4.1.2 as well. 

libphp4.so *is* made, but strangely enough its located in the '.libs' directory instead of 'libs', which 'make install' chokes on. I used the following work around for the 'make-install' issue (cp ./.libs/* ./libs), but then the server choked on server-startup.

I got some more information when I discovered that in my case, iPlanet is recieving signal 11/segmentation fault and trying to dump core when it 'hangs'. It's the uxwdog process that restarts it/keeps it from crashing, giving the impression that the server is 'frozen'.

In order to get a core file and some more info:

Make sure the account you are running the server as, can write to "/usr/netscape/server4/https-<servername>/config/core". By default, the core file should be located there. Make sure that the filesystem this
dir is in has enough space for a corefile.

Make sure there is no limit set for dumping core for the user-id the server is running under, by checking the users stanza in '/etc/security/limits' (set core=-1).

start the httpd manually (instead of using the 'start' script) by doing:
cd /usr/netscape/server4/bin/https/bin
./ns-httpd -d /usr/netscape/server4/https-servername>/config

Also, check the aix error log for messages by doing:
errpt -a | more

If you are running syslog, check that logfile too for messages from uxwdog.
 [2002-10-20 01:45 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-11-05 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 16:03:40 2021 UTC