php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15372 Apache hangs with PHP 4.1.1+oci8
Submitted: 2002-02-04 17:56 UTC Modified: 2002-04-13 09:10 UTC
From: mindeman at btinet dot net Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 4.1.1 OS: Solaris 8
Private report: No CVE-ID: None
 [2002-02-04 17:56 UTC] mindeman at btinet dot net
I built PHP 4.1.1 as a DSO module using GCC 2.95.3 (which was installed from a sunfreeware package).  The Oracle client is version 8.1.7.  ORACLE_HOME was properly set (I was able to connect to Oracle through the sqlplus client).  The configure line was:

./configure --with-oci8

Configuration, compilation, and installation proceded without errors.  Apache started without error (error_log set to debug level).

When attempting to access any URL on the server, the client recieves no response and does not time out.  The request does not show up in the access_log on the server.  The error_log shows nothing for about 10 minutes, then a series of the following errors appears:

sgslun: unable to create SOSD endpoint
sgslun: unable to create SOSD endpoint
[Mon Feb  4 16:42:35 2002] [error] (24)Too many open files: accept: (client socket)


When PHP is built without oci8 support, Apache processes requests normally.  PHP built with other modules (i.e. CURL, GD), and without oci8 does not have this behavior.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-05 16:36 UTC] mindeman at btinet dot net
I rebuilt PHP without any modules, and built the oci8 PHP module as a dynamic module.  If I load oci8.so in a page using the dl() function, the page works as expected.  
However, when I add oci8.so to the php.ini file like so:

extension=oci8.so

The webserver exibits the same behavior as I detailed before.
 [2002-04-13 09:10 UTC] thies@php.net
The bug system is not the appropriate forum for asking support
questions. For a list of a range of more appropriate places to ask
for help using PHP, please visit http://www.php.net/support.php

ther seems to be some conflict using gcc to link the oracle-libs shred into the php-apache chain. nothing i can do from here. maybe ask the list.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 29 07:01:30 2020 UTC