php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15371 corrupted/erroneous data output
Submitted: 2002-02-04 16:49 UTC Modified: 2002-08-08 10:25 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (100.0%)
From: jedgar at woodtruss dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.1.1 OS: Red Hat 7.2
Private report: No CVE-ID: None
 [2002-02-04 16:49 UTC] jedgar at woodtruss dot com
We are attempting to MSSQL using FreeTDS 0.53 running 7.0. I have successfully connected to the MSSQL 2000 database; however, when I output the results of a query, it appears as though trailing characters from the previous row are being added to the current row. This happens whether I output using the ADODB system, or use PHP's Sybase commands. However, when I use SQSH 2.1, it outputs the data correctly. This points to PHP and its Sybase functions, as far as I can tell. Here is what the native data look like in MSSQL:

Education & Technical
Products
Marketing
Management
Membership
Legislative Issues
Links & Resources
News & Calendar
Career Center
Inside WTCA
Affiliates
Control Panel/Options
Site Map

and here is the output from PHP:

Education & Technical
Products & Tech
Marketing& Techi
Management Techia
Membership Techia
Legislative Issuesa
Links & Resourcesa
News & Calendarsa
Career Centerrsa
Inside WTCArrsa
Affiliatesrrsa
Control Panel/Options
Site Mapanel/Op

As you can see, it's adding characters from the previous row. The pattern is not perfectly consistent, however. We are currently using the dblib, and trying to configure ctlib, but aren't successful yet.

Thank you for your time and attention.

Jay Edgar

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-04 16:57 UTC] jedgar at woodtruss dot com
Of course, right after submitting the report, I tried changing the FreeTDS version to 4.2. The data was output correctly. However, why did SQSH work at 7.0, when it sits on top of FreeTDS, and not PHP?
 [2002-02-04 17:27 UTC] jedgar at woodtruss dot com
ok, this only gets wierder and wierder. I tried simply reloading the page again and again. Output would be correct several times, then incorrect, then correct, etc. We rebooted the Linux server, and now it is only incorrect.

Sorry for the multiple additions.  /jte
 [2002-04-08 09:45 UTC] bs at corpeople dot dk
I have experienced the same error using using FreeTDS 0.53 running 7.0 on Red Hat 7.2. The only difference is that I'm running PHP 4.1.2.

It helped switching to FreeTDS version 4.2.
 [2002-08-08 10:25 UTC] tal@php.net
Marking as bogus as updating FreeTDS fixes this bug.

-Tal
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 17:01:27 2019 UTC