php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15364 Compile Fails as CGI with INFORMIX on SCO
Submitted: 2002-02-04 06:23 UTC Modified: 2002-07-24 01:00 UTC
From: paul dot gardiner at barleychalu dot co dot uk Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.1.1 OS: SCO Openserver 5.0.4
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-02-04 06:23 UTC] paul dot gardiner at barleychalu dot co dot uk
Hi,

I can compile PHP 4.1.1 with Apache 1.3.20, Informix 7.2x, zlib, GD, PDFlib. But when trying to compile PHP as just a CGI for non-web use it fails.

Using gnu build utils: gcc, gmake etc.

configure line used:
configure --without-mysql --with-informix

I've tried messing about with different combinations of libraries but even if I get it a bit further,sometimes through make, it then fails on make install. 

I really need to get this to work otherwise I'm ******!

If any further info is needed please ask.

Regards,
- Paul -

Error output:

*** Warning: Linking the shared library libphp4.la against the
*** static library /usr/lib/libgen.a is not portable!
/bin/ksh /usr/src/php-4.1.1/libtool --silent --mode=link gcc -I. -I/usr/src/php-
4.1.1/ -I/usr/src/php-4.1.1/main -I/usr/src/php-4.1.1 -I/usr/src/php-4.1.1/Zend 
-I/usr/informix/incl/esql -I/usr/src/php-4.1.1/ext/xml/expat  -I/usr/src/php-4.1
.1/TSRM -g -O2   -o php -export-dynamic  stub.lo libphp4.la 
Undefined                       first referenced
 symbol                             in file
getspnam                            /usr/informix/lib/esql/libifos.so
php: fatal error: Symbol referencing errors. No output written to php
collect2: ld returned 1 exit status
gmake[1]: *** [php] Error 1
gmake[1]: Leaving directory `/usr/src/php-4.1.1'
gmake: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-15 20:41 UTC] sniper@php.net
This snapshot _should_ fix the problem:

http://snaps.php.net/php4-latest.tar.gz

It works fine for me with the 2.70.UC3 which is the latest I found from the informix site. (Didn't I fix this stuff long time ago?) Please try the snapshot. We have new build system
in PHP 4.3.0-dev so..


--Jani

 [2002-07-24 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 03:01:26 2019 UTC