php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15334 no way to upload to a virtual domain
Submitted: 2002-02-01 17:53 UTC Modified: 2002-02-02 06:16 UTC
From: carlo_rocchi at tin dot it Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.1.1 OS: FreeBSD 4.4
Private report: No CVE-ID: None
 [2002-02-01 17:53 UTC] carlo_rocchi at tin dot it
using phpMyAdmin to upload a SQL query file, Apache reports the following error:

***********************************************************

Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/bogus.org/httpdocs/sql/read_dump.php on line 220

Warning: fopen("/usr/local/psa/home/vhosts/anotherone.com/httpdocs/_php_upload_tmp/php66Xwh8", "r") - Operation not permitted in /usr/local/psa/home/vhosts/bogus.org/httpdocs/sql/read_dump.php on line 220

Warning: Supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/bogus.org/httpdocs/sql/read_dump.php on line 220

**********************************************************

Please notice that Apache is referring to two different virtual domains, "bogus.org" and "anotherone.com" !!!
I was uploading to bogus.org and Apache reported trying to fopen on anotherone.com!!
Is it impossible to perform uploads on a server that hosts virtual domains? It shouldnt, should it....


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-02 06:16 UTC] sander@php.net
Not a bug. Configuration problem. Ask support on the appropriate mailinglist.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Mar 02 14:01:23 2021 UTC