|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15324 CGI version (php.exe) times out
Submitted: 2002-02-01 10:27 UTC Modified: 2002-07-19 01:00 UTC
Avg. Score:4.4 ± 0.8
Reproduced:13 of 13 (100.0%)
Same Version:5 (38.5%)
Same OS:7 (53.8%)
From: isitlive at altavista dot com Assigned:
Status: No Feedback Package: IIS related
PHP Version: 4.1.1 OS: Win2K
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-02-01 10:27 UTC] isitlive at altavista dot com
I attempted to use php.exe (with IIS) rather than the ISAPI module of PHP 4.1.1, as the ISAPI consistently crashes after laying dormant for a period of time in IIS. This bug is alluded to in the latest release notes, and I don't believe it has been solved.

Having been warned that the ISAPI is not stable, I decided to run the CGI. I followed the installation instructions, and granted execute access for c:\php to IISUSR_computername

Problem is, the exe hangs and eventually produces a timeout error in IIS. I am using file includes on each of my pages.


The script started from the URL '/index.php' with parameters '' has not responded within the configured timeout period.  The HTTP server is terminating the script. 
For additional information specific to this message please visit the Microsoft Online Support site located at: 



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-01 18:39 UTC] isitlive at altavista dot com
note: I think we may have isolated the ISAPI problem...4.1.1 seems to crash in IIS (Win2K) after some period of dormancy only if it is *not* installed as an ISAPI filter as well as an ISAPI application, contrary to the advice given in the installation notes.
 [2002-02-25 21:28 UTC] WPinegar at healthtech dot net
I've seen the same problem.  You're right, adding the ISAPI filter does solve the problem.
 [2002-03-15 20:08 UTC] max at artco dot com
I had the same problem running php 4.04 as CGI on WinNT 4.0.  I found that if the registry key (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip\parameters\SynAttackProtect = 2) exists and is set I get the bug that is discussed in this report. By deleteing the SynAttackProtect key, I am no longer get the "The script started fromt he URL...." error and my server no longer crashes.

Before removeing the SynAttackProtect key from the registry I would get the above error and then my smpt server and ftp services would stop responding, and my web service  would stop after 5-10 minutes after the smtp and ftp untill eventually the server crashed and needed to be restarted.

for more info on the SynAttackProtect registry value you can visit microsoft KB#;en-us;Q315669
 [2002-06-18 05:39 UTC]
Is this fixed with PHP 4.2.1?

 [2002-07-19 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-08-11 13:48 UTC] nagashankarp at yahoo dot com
I get the same error, i am using the PHP Verion 4.3.9

after 5 minutes of this error, my IIS would hang, and i have to restart IIS, if you have a soluton let me know at the earliest.

 [2006-03-09 11:20 UTC] shaikh at cats-net dot com
I installed PHP 5.1.2 on WIN2k server with IIS 5, Below is the procedure followed to install PHP

Download the PHP binary for Windows NT/2000 from here.
Download the CGI binary plus API version.

Extract to a directory of your choice. (eg. d:\PHP4)

Copy php4_ts.dll (located in the PHP4 directory) to your windows\system32 directory.

Rename php.ini-dist to php.ini & move it to your WINDOWS directory (c:\winnt)

Open php.ini in an text editor such as notepad and change the following settings:

'extension_dir' to: c:\path\to\php\extensions

'doc_root' to point to your webservers document_root. ex: c:\inetpub\wwwroot

'session.save_path' The ISUR account has must full access to this directory

If you are running NTFS, which you should be, you will need to give the IUSR_MACHINENAME Execute permissions on your document root and the PHP directory. 

If you downloaded version 4.23 or greater, do a seach on cgi.force_redirect and make sure to set it to 0 - in fact you have to turn this feature off in order to run PHP on IIS Web Servers

Open the Internet Services Manager

Right click the top level icon (your computer name) click Properties

Click the Edit button in the Master Properties box to edit the WWW Service properties.

Click the 'Home Directory' tab

Click the 'Configuration' button.

Click the 'Add' button to add an Application Mapping.

Click 'Browse' and find the path to php.exe as the Executable Use .php as the extension and check the Script engine checkbox.

NOTE: Some people want to use the ISAPI filter - you are more than welcome to try it but I have not had great success with it & the people that write PHP suggest that you use the cgi version (exe). If you use the isapi filter in a prodcution environment please drop me a note. 

Click 'OK', 'Select All', 'OK' and 'OK'. 

You should be back at the Internet Service Manager application again.

You must now restart IIS. (Action, Restart IIS)

The above procedure works fine with XP Prof, but doesnt seems to be working on WIN2K server,

Has any one faced similar problem...
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 21 07:01:34 2024 UTC