php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15270 make install fails
Submitted: 2002-01-29 02:41 UTC Modified: 2002-07-18 01:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: zigazou at free dot fr Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.1.1 OS: UnixWare 7.1.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-01-29 02:41 UTC] zigazou at free dot fr
Hi !

We are working with this :
- IBM NetFinity 5100, bi-processor Pentium III
- UnixWare 7.1.1 with loads of patches
- Apache 1.3.23 (also with 1.3.19)
- PHP 4.1.1 (also with 4.0.6)
- Informix SE 7.23.UC1
- ESQL/C 9.21.UC1
- GCC 2.95.2 19991024
- gmake 3.78.1
- Bison 1.32

The 'configure' script generates an 'incorrect' Makefile in the root directory of PHP.

It contains this block :
install-sapi:
        @$(LIBTOOL) --silent --mode=install cp libphp4.la $(phptempdir)/libphp4.la >/dev/null 2>&1
        -@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
        -@if test ! -r $(phptempdir)/libphp4.$(SHLIB_SUFFIX_NAME); then \
                for i in 0.0.0 0.0 0; do \
                        if test -r $(phptempdir)/libphp4.$(SHLIB_SUFFIX_NAME).$$i; then \
                                $(LN_S) $(phptempdir)/libphp4.$(SHLIB_SUFFIX_NAME).$$i $(phptempdir)/libphp4.$(SHLIB_SUFFIX_NAME); \
                                break; \
                        fi; \
                done; \
        fi
        $(INSTALL_IT)

It lacks an '\' just after the last 'fi' instruction.
It doesn't work with the 'make' utility shipped with UnixWare 7.1.1
It works with the GNU 'gmake' utility.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-15 21:11 UTC] sniper@php.net
Does this happen with the latest CVS snapshot?
Also, what exactly is the error?

I think it's better use GNU make anyway..?

 [2002-07-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 13:01:28 2019 UTC